aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Filter-Crypto
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-11-05 12:10:52 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-11-05 12:10:52 +0000
commit91d8f822072a182be270dece1d9c8e938b16c6fc (patch)
tree533fda05b64e2dcfedcb09f8ecdb91642319f093 /security/p5-Filter-Crypto
parent9eb35d4b34a65cdaa402b8f376c81873cc714746 (diff)
downloadports-91d8f822072a182be270dece1d9c8e938b16c6fc.tar.gz
ports-91d8f822072a182be270dece1d9c8e938b16c6fc.zip
Add p5-Filter-Crypto 1.00,
create runnable Perl files encrypted with OpenSSL libcrypto.
Notes
Notes: svn path=/head/; revision=120849
Diffstat (limited to 'security/p5-Filter-Crypto')
-rw-r--r--security/p5-Filter-Crypto/Makefile35
-rw-r--r--security/p5-Filter-Crypto/distinfo2
-rw-r--r--security/p5-Filter-Crypto/pkg-descr19
-rw-r--r--security/p5-Filter-Crypto/pkg-plist18
4 files changed, 74 insertions, 0 deletions
diff --git a/security/p5-Filter-Crypto/Makefile b/security/p5-Filter-Crypto/Makefile
new file mode 100644
index 000000000000..094be56b9f7f
--- /dev/null
+++ b/security/p5-Filter-Crypto/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Filter-Crypto
+# Date created: 04 November 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Filter-Crypto
+PORTVERSION= 1.00
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Filter
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Create runnable Perl files encrypted with OpenSSL libcrypto
+
+BUILD_DEPENDS= ${SITE_PERL}/PAR/Filter.pm:${PORTSDIR}/devel/p5-PAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+USE_OPENSSL= yes
+CONFIGURE_ARGS= --prefix-dir=${OPENSSLBASE} --defaults
+
+MAN1= crypt_file.1
+MAN3= Filter::Crypto.3 Filter::Crypto::CryptFile.3 \
+ Filter::Crypto::Decrypt.3 PAR::Filter::Crypto.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Perl 5.6 or newer required. Install lang/perl5.8 or lang/perl5 and try again."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Filter-Crypto/distinfo b/security/p5-Filter-Crypto/distinfo
new file mode 100644
index 000000000000..e38c70539133
--- /dev/null
+++ b/security/p5-Filter-Crypto/distinfo
@@ -0,0 +1,2 @@
+MD5 (Filter-Crypto-1.00.tar.gz) = 82a643c15acd4493bf1bba5920b156cc
+SIZE (Filter-Crypto-1.00.tar.gz) = 93909
diff --git a/security/p5-Filter-Crypto/pkg-descr b/security/p5-Filter-Crypto/pkg-descr
new file mode 100644
index 000000000000..e83dc4c2c0c5
--- /dev/null
+++ b/security/p5-Filter-Crypto/pkg-descr
@@ -0,0 +1,19 @@
+The Filter-Crypto distribution provides the means to convert your Perl
+files into an encrypted, yet still runnable, format to hide the source
+code from casual prying eyes.
+
+This is achieved using a Perl source code filter. The encrypted files,
+produced using the Filter::Crypto::CryptFile module automatically have
+one (unencrypted) line added to the start of them which loads the
+Filter::Crypto::Decrypt module. The latter is a Perl source code filter
+which decrypts the remaining (encrypted) part of the Perl file
+on-the-fly when it is run. See perlfilter if you want to know more
+about how Perl source code filters work.
+
+Encrypted files can also be produced more conveniently using the
+crypt_file script, or (if you also have the PAR module available) using
+the PAR::Filter::Crypto module. The latter can be utilised by the
+standard PAR tools to produce PAR archives in which your Perl files are
+encrypted.
+
+WWW: http://search.cpan.org/dist/Filter-Crypto/
diff --git a/security/p5-Filter-Crypto/pkg-plist b/security/p5-Filter-Crypto/pkg-plist
new file mode 100644
index 000000000000..546c07ea04cf
--- /dev/null
+++ b/security/p5-Filter-Crypto/pkg-plist
@@ -0,0 +1,18 @@
+bin/crypt_file
+%%SITE_PERL%%/%%PERL_ARCH%%/Filter/Crypto.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Filter/Crypto/CryptFile.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Filter/Crypto/Decrypt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/PAR/Filter/Crypto.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto/CryptFile/CryptFile.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto/CryptFile/CryptFile.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto/Decrypt/Decrypt.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto/Decrypt/Decrypt.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Filter/Crypto
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Filter 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/PAR/Filter
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/PAR 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto/CryptFile
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto/Decrypt
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter/Crypto
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filter 2>/dev/null || true