aboutsummaryrefslogtreecommitdiff
path: root/security/p5-GSSAPI
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-03-28 09:57:33 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-03-28 09:57:33 +0000
commitc4ee7c086c84d971f72da678f7ed0e00e370a41f (patch)
tree86af13f0a4588f976fef7ab063851141ebc0b076 /security/p5-GSSAPI
parentddf2531e1408d4ad219318074fb9d40e550f6780 (diff)
downloadports-c4ee7c086c84d971f72da678f7ed0e00e370a41f.tar.gz
ports-c4ee7c086c84d971f72da678f7ed0e00e370a41f.zip
Add security/p5-GSSAPI 0.20, a Perl extension providing access to the
GSSAPIv2 library.
Notes
Notes: svn path=/head/; revision=158298
Diffstat (limited to 'security/p5-GSSAPI')
-rw-r--r--security/p5-GSSAPI/Makefile31
-rw-r--r--security/p5-GSSAPI/distinfo3
-rw-r--r--security/p5-GSSAPI/pkg-descr5
-rw-r--r--security/p5-GSSAPI/pkg-plist10
4 files changed, 49 insertions, 0 deletions
diff --git a/security/p5-GSSAPI/Makefile b/security/p5-GSSAPI/Makefile
new file mode 100644
index 000000000000..476bc298b257
--- /dev/null
+++ b/security/p5-GSSAPI/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: security/p5-GSSAPI
+# Date created: 28 March 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GSSAPI
+PORTVERSION= 0.20
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AG/AGROLMS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= GSSAPI - Perl extension providing access to the GSSAPIv2 library
+
+PERL_CONFIGURE= yes
+
+MAN3= GSSAPI.3 \
+ GSSAPI::OID.3 \
+ GSSAPI::OID::Set.3 \
+ GSSAPI::Status.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-GSSAPI/distinfo b/security/p5-GSSAPI/distinfo
new file mode 100644
index 000000000000..c3b1bdd1a9d8
--- /dev/null
+++ b/security/p5-GSSAPI/distinfo
@@ -0,0 +1,3 @@
+MD5 (GSSAPI-0.20.tar.gz) = 45f28bf66ff2a29adf1ec24055fe7ac1
+SHA256 (GSSAPI-0.20.tar.gz) = 98213fd3a507355bfa16744eb8a1675084e3d2692bf1495ebe4ceed9a62e525e
+SIZE (GSSAPI-0.20.tar.gz) = 26005
diff --git a/security/p5-GSSAPI/pkg-descr b/security/p5-GSSAPI/pkg-descr
new file mode 100644
index 000000000000..26caeee886de
--- /dev/null
+++ b/security/p5-GSSAPI/pkg-descr
@@ -0,0 +1,5 @@
+This module gives access to the routines of the GSSAPI library,
+as described in rfc2743 and rfc2744 and implemented by the
+Kerberos-1.2 distribution from MIT.
+
+WWW: http://search.cpan.org/dist/GSSAPI/
diff --git a/security/p5-GSSAPI/pkg-plist b/security/p5-GSSAPI/pkg-plist
new file mode 100644
index 000000000000..e125d4e56459
--- /dev/null
+++ b/security/p5-GSSAPI/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/GSSAPI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/GSSAPI/OID.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/GSSAPI/OID/Set.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/GSSAPI/Status.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GSSAPI/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GSSAPI/GSSAPI.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GSSAPI/GSSAPI.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GSSAPI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GSSAPI/OID
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GSSAPI