aboutsummaryrefslogtreecommitdiff
path: root/security/p5-IO-Async-SSL
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-02-21 17:17:54 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-02-21 17:17:54 +0000
commit79cf1453ad295f9b2ba39812dc76bf3519d315e8 (patch)
tree4bd2f836a750fd1ea77f119e6963c2444509b720 /security/p5-IO-Async-SSL
parent5e7b5ec0af35ee764c215a4f6a574f00a16f587e (diff)
downloadports-79cf1453ad295f9b2ba39812dc76bf3519d315e8.tar.gz
ports-79cf1453ad295f9b2ba39812dc76bf3519d315e8.zip
- Add BUILD_DEPENDS
- Sort MAN3 - Take maintainership - Cleanup Makefile header - Reformat pkg-descr - Complete PLIST
Notes
Notes: svn path=/head/; revision=312730
Diffstat (limited to 'security/p5-IO-Async-SSL')
-rw-r--r--security/p5-IO-Async-SSL/Makefile14
-rw-r--r--security/p5-IO-Async-SSL/pkg-descr11
-rw-r--r--security/p5-IO-Async-SSL/pkg-plist8
3 files changed, 19 insertions, 14 deletions
diff --git a/security/p5-IO-Async-SSL/Makefile b/security/p5-IO-Async-SSL/Makefile
index 6167ef749ec6..07d07f11bef2 100644
--- a/security/p5-IO-Async-SSL/Makefile
+++ b/security/p5-IO-Async-SSL/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-IO-Async-SSL
-# Date created: 2011-03-07
-# Whom: <ports@c0decafe.net>
-#
+# Created by: <ports@c0decafe.net>
# $FreeBSD$
-#
PORTNAME= IO-Async-SSL
PORTVERSION= 0.06
@@ -12,14 +8,16 @@ MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:PEVANS
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Use SSL/TLS with IO::Async
-RUN_DEPENDS= p5-IO-Async>=0.29:${PORTSDIR}/devel/p5-IO-Async\
+BUILD_DEPENDS= p5-IO-Async>=0.29:${PORTSDIR}/devel/p5-IO-Async\
p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= IO::Async::SSLStream.3 IO::Async::SSL.3
+MAN3= IO::Async::SSL.3 \
+ IO::Async::SSLStream.3
.include <bsd.port.mk>
diff --git a/security/p5-IO-Async-SSL/pkg-descr b/security/p5-IO-Async-SSL/pkg-descr
index 3c441809587f..e9c023b605c8 100644
--- a/security/p5-IO-Async-SSL/pkg-descr
+++ b/security/p5-IO-Async-SSL/pkg-descr
@@ -1,4 +1,9 @@
-This module extends existing IO::Async classes with extra methods to
-allow the use of SSL or TLS-based connections using IO::Socket::SSL.
+This module extends existing IO::Async classes with extra methods to allow the
+use of SSL or TLS-based connections using IO::Socket::SSL. It does not directly
+provide any methods or functions of its own.
-WWW: http://search.cpan.org/dist/IO-Async-SSL/
+Primarily, it provides SSL_connect and SSL_listen, which yield
+IO::Socket::SSL-upgraded socket handles or IO::Async::SSLStream instances, and
+two forms of SSL_upgrade to upgrade an existing TCP connection to use SSL.
+
+WWW: http://search.cpan.org/dist/IO-Async-SSL/
diff --git a/security/p5-IO-Async-SSL/pkg-plist b/security/p5-IO-Async-SSL/pkg-plist
index 816642e40496..4109f33187b7 100644
--- a/security/p5-IO-Async-SSL/pkg-plist
+++ b/security/p5-IO-Async-SSL/pkg-plist
@@ -1,6 +1,8 @@
-@comment $FreeBSD$
-%%SITE_PERL%%/IO/Async/SSLStream.pm
%%SITE_PERL%%/IO/Async/SSL.pm
+%%SITE_PERL%%/IO/Async/SSLStream.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Async/SSL/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Async/SSL
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Async/SSL
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO
+@dirrmtry %%SITE_PERL%%/IO/Async
+@dirrmtry %%SITE_PERL%%/IO