aboutsummaryrefslogtreecommitdiff
path: root/security/p5-IO-Socket-SSL/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-09-21 23:22:21 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-09-21 23:22:21 +0000
commit94b64b934c1aac6406a39d9d89c9081e62bc2b79 (patch)
treecd79ec856da859998f62829bf654649c75cd3738 /security/p5-IO-Socket-SSL/Makefile
parentc5ed4911be1508c001a46a904a3ad413451864fc (diff)
downloadports-94b64b934c1aac6406a39d9d89c9081e62bc2b79.tar.gz
ports-94b64b934c1aac6406a39d9d89c9081e62bc2b79.zip
Notes
Diffstat (limited to 'security/p5-IO-Socket-SSL/Makefile')
-rw-r--r--security/p5-IO-Socket-SSL/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/security/p5-IO-Socket-SSL/Makefile b/security/p5-IO-Socket-SSL/Makefile
index a46ef3d3c3b3..770b36db907d 100644
--- a/security/p5-IO-Socket-SSL/Makefile
+++ b/security/p5-IO-Socket-SSL/Makefile
@@ -6,20 +6,32 @@
#
PORTNAME= IO-Socket-SSL
-PORTVERSION= 0.97
+PORTVERSION= 1.01
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IO
PKGNAMEPREFIX= p5-
-MAINTAINER= scrappy@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to SSL sockets
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Net-SSLeay>=1.21:${PORTSDIR}/security/p5-Net-SSLeay
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= IO::Socket::SSL.3
-.include <bsd.port.mk>
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/example/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500702
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>