aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-OpenID-Common
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-07 07:03:22 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-07 07:03:22 +0000
commit17555474b6fc33c61f550bbde2d21d2c6a1e2f80 (patch)
tree6c94e3991d067f1ccb7901c79c29bbbe7a16fd3b /security/p5-Net-OpenID-Common
parent68b33e5367684762870840940355d4c18750017f (diff)
downloadports-17555474b6fc33c61f550bbde2d21d2c6a1e2f80.tar.gz
ports-17555474b6fc33c61f550bbde2d21d2c6a1e2f80.zip
Net::OpenID::Common - Libraries shared between Net::OpenID::Consumer
Notes
Notes: svn path=/head/; revision=285224
Diffstat (limited to 'security/p5-Net-OpenID-Common')
-rw-r--r--security/p5-Net-OpenID-Common/Makefile46
-rw-r--r--security/p5-Net-OpenID-Common/distinfo2
-rw-r--r--security/p5-Net-OpenID-Common/pkg-descr4
-rw-r--r--security/p5-Net-OpenID-Common/pkg-plist16
4 files changed, 68 insertions, 0 deletions
diff --git a/security/p5-Net-OpenID-Common/Makefile b/security/p5-Net-OpenID-Common/Makefile
new file mode 100644
index 000000000000..4ca7b5c77057
--- /dev/null
+++ b/security/p5-Net-OpenID-Common/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: p5-Net-OpenID-Server
+# Date created: 7 Nov 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenID-Common
+PORTVERSION= 1.13
+CATEGORIES= security net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Libraries shared between Net::OpenID::Consumer and Net::OpenID::Server
+
+BUILD_DEPENDS= p5-Crypt-DH-GMP>=0:${PORTSDIR}/net/p5-Crypt-DH-GMP \
+ p5-Email-MIME-ContentType>=0:${PORTSDIR}/mail/p5-Email-MIME-ContentType \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS= p5-Crypt-DH-GMP>=0:${PORTSDIR}/net/p5-Crypt-DH-GMP \
+ p5-Email-MIME-ContentType>=0:${PORTSDIR}/mail/p5-Email-MIME-ContentType \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OpenID::Common.3 \
+ Net::OpenID::Extension.3 \
+ Net::OpenID::Extension::SimpleRegistration.3 \
+ Net::OpenID::ExtensionMessage.3 \
+ Net::OpenID::IndirectMessage.3 \
+ Net::OpenID::URIFetch.3 \
+ Net::OpenID::Yadis.3 \
+ Net::OpenID::Yadis::Service.3
+
+.if defined(MAINTAINER_MODE)
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} test
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/p5-Net-OpenID-Common/distinfo b/security/p5-Net-OpenID-Common/distinfo
new file mode 100644
index 000000000000..c6b5c7adca49
--- /dev/null
+++ b/security/p5-Net-OpenID-Common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-OpenID-Common-1.13.tar.gz) = 93a9195a04a50f9dd823bd4ee3f26e460600babb69ebc61982a0916ea7894a25
+SIZE (Net-OpenID-Common-1.13.tar.gz) = 27826
diff --git a/security/p5-Net-OpenID-Common/pkg-descr b/security/p5-Net-OpenID-Common/pkg-descr
new file mode 100644
index 000000000000..815ba656bc07
--- /dev/null
+++ b/security/p5-Net-OpenID-Common/pkg-descr
@@ -0,0 +1,4 @@
+Net::OpenID::Common - Libraries shared between Net::OpenID::Consumer
+and Net::OpenID::Server
+
+WWW: https://metacpan.org/release/Net-OpenID-Common
diff --git a/security/p5-Net-OpenID-Common/pkg-plist b/security/p5-Net-OpenID-Common/pkg-plist
new file mode 100644
index 000000000000..7f0f68b0dae0
--- /dev/null
+++ b/security/p5-Net-OpenID-Common/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Net/OpenID/Common.pm
+%%SITE_PERL%%/Net/OpenID/Extension.pm
+%%SITE_PERL%%/Net/OpenID/Extension/SimpleRegistration.pm
+%%SITE_PERL%%/Net/OpenID/ExtensionMessage.pm
+%%SITE_PERL%%/Net/OpenID/IndirectMessage.pm
+%%SITE_PERL%%/Net/OpenID/URIFetch.pm
+%%SITE_PERL%%/Net/OpenID/Yadis.pm
+%%SITE_PERL%%/Net/OpenID/Yadis/Service.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Common/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Common
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/OpenID/Yadis
+@dirrmtry %%SITE_PERL%%/Net/OpenID/Extension
+@dirrmtry %%SITE_PERL%%/Net/OpenID
+@dirrmtry %%SITE_PERL%%/Net