aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-SAML
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-03-01 16:16:17 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-03-01 16:16:17 +0000
commit29500f0ed71ccebac7e408f1d3f734c405b89e98 (patch)
tree878a816bdd69e6f247d916ed9d9fa02b95276cfa /security/p5-Net-SAML
parent42f6bb2d88b9035a93c83c7e4a9756dcb1ab6fbe (diff)
downloadports-29500f0ed71ccebac7e408f1d3f734c405b89e98.tar.gz
ports-29500f0ed71ccebac7e408f1d3f734c405b89e98.zip
Update zxid and p5-Net-SAML to 1.42.
While here: - Strip the p5-Net-SAML XS module. - use Uses:localbase in zxid - Replace obtuse compound statements with more straightforward invocations - Add spacing for legibility
Notes
Notes: svn path=/head/; revision=409877
Diffstat (limited to 'security/p5-Net-SAML')
-rw-r--r--security/p5-Net-SAML/Makefile5
-rw-r--r--security/p5-Net-SAML/distinfo4
-rw-r--r--security/p5-Net-SAML/files/patch-SAML__wrap.c13
3 files changed, 6 insertions, 16 deletions
diff --git a/security/p5-Net-SAML/Makefile b/security/p5-Net-SAML/Makefile
index 8aa15626cbe6..739ac5e66b43 100644
--- a/security/p5-Net-SAML/Makefile
+++ b/security/p5-Net-SAML/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= Net-SAML
-PORTVERSION= 1.30
+PORTVERSION= 1.42
CATEGORIES= security perl5
MASTER_SITES= http://zxid.org/ \
CPAN
@@ -31,6 +31,9 @@ post-patch:
@${REINPLACE_CMD} -e '/INC/ s|-I\.\.|& -I${LOCALBASE}/include|; /LIBS/ s|-L\.\.|-L${LOCALBASE}/lib|; s|-ldl||' ${WRKSRC}/Makefile.PL
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/SAML/SAML.so
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/ && ${INSTALL_SCRIPT} ../zxid.pl ../zxidhlo.pl ${STAGEDIR}${EXAMPLESDIR})
diff --git a/security/p5-Net-SAML/distinfo b/security/p5-Net-SAML/distinfo
index ba2246afb3d5..a0eca9a61cde 100644
--- a/security/p5-Net-SAML/distinfo
+++ b/security/p5-Net-SAML/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zxid-1.30.tgz) = 5d8353777064293ec58495953c576f6ef71f6818afd9877a8e81d0f4ca9eba1b
-SIZE (zxid-1.30.tgz) = 2132144
+SHA256 (zxid-1.42.tgz) = 8b936c8a011cc6fc56d19c6a83cd2dede36bb16b6453b81e45ee8811b9272b10
+SIZE (zxid-1.42.tgz) = 2164542
diff --git a/security/p5-Net-SAML/files/patch-SAML__wrap.c b/security/p5-Net-SAML/files/patch-SAML__wrap.c
deleted file mode 100644
index 7a00ec5f181b..000000000000
--- a/security/p5-Net-SAML/files/patch-SAML__wrap.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- SAML_wrap.c.orig 2014-11-06 12:22:29 UTC
-+++ SAML_wrap.c
-@@ -1442,7 +1442,9 @@ SWIG_Perl_SetModule(swig_module_info *mo
- #undef eof
- #endif
- #ifdef bool
-- #undef bool
-+ #ifndef __bool_true_false_are_defined
-+ #undef bool
-+ #endif
- #endif
- #ifdef close
- #undef close