aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-SAML
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-23 18:35:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-23 18:35:32 +0000
commit3cdffc0e2db9e174ff298f5971c9e0deead7c666 (patch)
tree5dc1e6f26e50180a2a9984651322ca10cbc8eaee /security/p5-Net-SAML
parent9b17d578745c7d72c90a85e5e8838962aa48a321 (diff)
downloadports-3cdffc0e2db9e174ff298f5971c9e0deead7c666.tar.gz
ports-3cdffc0e2db9e174ff298f5971c9e0deead7c666.zip
- Update to 1.16
- Use REINPLACE_CMD instead of patch file - Fix shebang Changes: http://search.cpan.org/dist/zxid/Changes
Notes
Notes: svn path=/head/; revision=334692
Diffstat (limited to 'security/p5-Net-SAML')
-rw-r--r--security/p5-Net-SAML/Makefile8
-rw-r--r--security/p5-Net-SAML/distinfo4
-rw-r--r--security/p5-Net-SAML/files/patch-errmac.h14
3 files changed, 7 insertions, 19 deletions
diff --git a/security/p5-Net-SAML/Makefile b/security/p5-Net-SAML/Makefile
index d637e33f2b3f..8cd8c649874c 100644
--- a/security/p5-Net-SAML/Makefile
+++ b/security/p5-Net-SAML/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= Net-SAML
-PORTVERSION= 1.11
-PORTREVISION= 1
+PORTVERSION= 1.16
CATEGORIES= security perl5
MASTER_SITES= http://zxid.org/ \
CPAN
@@ -18,11 +17,14 @@ LICENSE= AL2
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
zxid:${PORTSDIR}/security/zxid
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
WRKSRC= ${WRKDIR}/${DISTNAME}/Net
+SHEBANG_FILES= ../zxid.pl ../zxidhlo.pl
+
post-patch:
+ @${REINPLACE_CMD} -e 's|hexdump|my&|' ${WRKSRC}/../errmac.h
@${REINPLACE_CMD} -e 's|/apps/openssl/std|${LOCALBASE}|' ${WRKSRC}/Makefile.PL
post-install:
diff --git a/security/p5-Net-SAML/distinfo b/security/p5-Net-SAML/distinfo
index 1bf6cb5a95ae..72a521e5fec8 100644
--- a/security/p5-Net-SAML/distinfo
+++ b/security/p5-Net-SAML/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zxid-1.11.tgz) = 369a26c8819ea9bce53e128e31e91e2e3ec38771101083c0a8df5dac2a2d5982
-SIZE (zxid-1.11.tgz) = 1999606
+SHA256 (zxid-1.16.tgz) = 995b8ceb3c002423b385c43e442e1dcb5691ab5bbacd2f87856dfd167249881e
+SIZE (zxid-1.16.tgz) = 2102718
diff --git a/security/p5-Net-SAML/files/patch-errmac.h b/security/p5-Net-SAML/files/patch-errmac.h
deleted file mode 100644
index f14b69e63996..000000000000
--- a/security/p5-Net-SAML/files/patch-errmac.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- ../errmac.h.orig 2013-02-10 20:04:39.000000000 +0800
-+++ ../errmac.h 2013-02-10 20:05:04.000000000 +0800
-@@ -445,9 +445,9 @@
- #define DD_XML_BLOB(cf, lk, len, xml) /* Documentative */
-
- int hexdmp(const char* msg, const char* p, int len, int max);
--int hexdump(const char* msg, const char* p, const char* lim, int max);
-+int myhexdump(const char* msg, const char* p, const char* lim, int max);
-
--#define HEXDUMP(msg, p, lim, max) if (zx_debug > 1) hexdump((msg), (p), (lim), (max))
-+#define HEXDUMP(msg, p, lim, max) if (zx_debug > 1) myhexdump((msg), (p), (lim), (max))
- #define DHEXDUMP(msg, p, lim, max) /* Disabled hex dump */
-
- #define DUMP_CORE() ASSERT(0)