aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-SAML
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2013-02-14 09:18:59 +0000
committerFrederic Culot <culot@FreeBSD.org>2013-02-14 09:18:59 +0000
commita1990a4dc00764f30889af52ff21a78678aa7e8d (patch)
treeac3630093f348105767e66984b817b00d055e7da /security/p5-Net-SAML
parent62abf6876b44247d491fb667b102d2c7469b6ba6 (diff)
downloadports-a1990a4dc00764f30889af52ff21a78678aa7e8d.tar.gz
ports-a1990a4dc00764f30889af52ff21a78678aa7e8d.zip
- Update to 1.11
PR: ports/176009 Submitted by: Gea-Suan Lin <gslin@gslin.org>
Notes
Notes: svn path=/head/; revision=312207
Diffstat (limited to 'security/p5-Net-SAML')
-rw-r--r--security/p5-Net-SAML/Makefile11
-rw-r--r--security/p5-Net-SAML/distinfo4
-rw-r--r--security/p5-Net-SAML/files/patch-errmac.h20
3 files changed, 15 insertions, 20 deletions
diff --git a/security/p5-Net-SAML/Makefile b/security/p5-Net-SAML/Makefile
index ed0d6dcfc18c..b22ea001681d 100644
--- a/security/p5-Net-SAML/Makefile
+++ b/security/p5-Net-SAML/Makefile
@@ -1,15 +1,10 @@
-# New ports collection makefile for: p5-Net-SAML
-# Date created: 2007-07-14
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
# $FreeBSD$
-#
PORTNAME= Net-SAML
-PORTVERSION= 1.05
+PORTVERSION= 1.11
CATEGORIES= security perl5
-MASTER_SITES= CPAN \
- http://zxid.org/
+MASTER_SITES= http://zxid.org/ \
+ CPAN
PKGNAMEPREFIX= p5-
DISTNAME= zxid-${PORTVERSION}
EXTRACT_SUFX= .tgz
diff --git a/security/p5-Net-SAML/distinfo b/security/p5-Net-SAML/distinfo
index c05df56e22a2..1bf6cb5a95ae 100644
--- a/security/p5-Net-SAML/distinfo
+++ b/security/p5-Net-SAML/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zxid-1.05.tgz) = 779de5245b026abfe73d4e7b9306c033c2dd600fc48c9d5eb0251f4c9914e190
-SIZE (zxid-1.05.tgz) = 1800009
+SHA256 (zxid-1.11.tgz) = 369a26c8819ea9bce53e128e31e91e2e3ec38771101083c0a8df5dac2a2d5982
+SIZE (zxid-1.11.tgz) = 1999606
diff --git a/security/p5-Net-SAML/files/patch-errmac.h b/security/p5-Net-SAML/files/patch-errmac.h
index 42c8ad15aa14..f14b69e63996 100644
--- a/security/p5-Net-SAML/files/patch-errmac.h
+++ b/security/p5-Net-SAML/files/patch-errmac.h
@@ -1,14 +1,14 @@
---- ../errmac.h.orig 2009-10-16 19:37:47.000000000 +0400
-+++ ../errmac.h 2009-10-30 00:39:36.000000000 +0300
-@@ -406,9 +406,9 @@
- #define DD(format,...) /* Documentative */
+--- ../errmac.h.orig 2013-02-10 20:04:39.000000000 +0800
++++ ../errmac.h 2013-02-10 20:05:04.000000000 +0800
+@@ -445,9 +445,9 @@
+ #define DD_XML_BLOB(cf, lk, len, xml) /* Documentative */
- int hexdmp(char* msg, char* p, int len, int max);
--int hexdump(char* msg, char* p, char* lim, int max);
-+int myhexdump(char* msg, char* p, char* lim, int max);
+ int hexdmp(const char* msg, const char* p, int len, int max);
+-int hexdump(const char* msg, const char* p, const char* lim, int max);
++int myhexdump(const char* msg, const char* p, const char* lim, int max);
--#define HEXDUMP(msg, p, lim, max) (zx_debug > 1 && hexdump((msg), (p), (lim), (max)))
-+#define HEXDUMP(msg, p, lim, max) (zx_debug > 1 && myhexdump((msg), (p), (lim), (max)))
+-#define HEXDUMP(msg, p, lim, max) if (zx_debug > 1) hexdump((msg), (p), (lim), (max))
++#define HEXDUMP(msg, p, lim, max) if (zx_debug > 1) myhexdump((msg), (p), (lim), (max))
#define DHEXDUMP(msg, p, lim, max) /* Disabled hex dump */
- #define ERR(format,...) (fprintf(stderr, "t %10s:%-3d %-16s %s E " format "\n", __FILE__, __LINE__, __FUNCTION__, ERRMAC_INSTANCE, __VA_ARGS__), fflush(stderr))
+ #define DUMP_CORE() ASSERT(0)