aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-SSLeay
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /security/p5-Net-SSLeay
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Notes
Diffstat (limited to 'security/p5-Net-SSLeay')
-rw-r--r--security/p5-Net-SSLeay/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/p5-Net-SSLeay/Makefile b/security/p5-Net-SSLeay/Makefile
index 400b20fc09dc..0ed27cff263d 100644
--- a/security/p5-Net-SSLeay/Makefile
+++ b/security/p5-Net-SSLeay/Makefile
@@ -5,24 +5,25 @@
# $FreeBSD$
#
-PORTNAME= p5-Net-SSLeay
+PORTNAME= Net-SSLeay
PORTVERSION= 1.05
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
-DISTNAME= Net_SSLeay.pm-1.05
+DISTNAME= Net_SSLeay.pm-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= andreas@FreeBSD.org
-.include <bsd.port.pre.mk>
-
RESTRICTED= "Cryptography"
-USE_PERL5= YES
+USE_PERL5= yes
+USE_OPENSSL= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::SSLeay.3
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ ${OPENSSLBASE} CC="${CC}" CCFLAGS="${CFLAGS}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>