aboutsummaryrefslogtreecommitdiff
path: root/security/p5-PGP-Sign
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /security/p5-PGP-Sign
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Notes
Notes: svn path=/head/; revision=29658
Diffstat (limited to 'security/p5-PGP-Sign')
-rw-r--r--security/p5-PGP-Sign/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index 24ef64201529..57b3b2b07ef9 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= p5-PGP-Sign
+PORTNAME= PGP-Sign
PORTVERSION= 0.16
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= PGP
-DISTNAME= PGP-Sign-0.16
+PKGNAMEPREFIX= p5-
MAINTAINER= croyle@gelemna.org
@@ -61,6 +61,7 @@ PGPV= ${PGP}
CONFIG_ARGS= PGPS=${PGPS} PGPV=${PGPV} PGPSTYLE=${PGPSTYLE}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL ${CONFIG_ARGS}
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ ${CONFIG_ARGS}
.include <bsd.port.mk>