aboutsummaryrefslogtreecommitdiff
path: root/security/p5-PGP-Sign
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-02 09:42:24 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-02 09:42:24 +0000
commit2feae3176da597f0db385a37f3557ea574d982c5 (patch)
treee0bb3494935ab927107445c06cf1bcde7c01b13c /security/p5-PGP-Sign
parente0de6f9eb7686fe9352b7ea4d191ce9b3005fcc8 (diff)
downloadports-2feae3176da597f0db385a37f3557ea574d982c5.tar.gz
ports-2feae3176da597f0db385a37f3557ea574d982c5.zip
- Add LICENSE
- Convert to new options framework - Removed obsolete dependency - Pass maintainership to submitter - Bump PORTREVISION - While I'm here: - Use LOCALBASE instead of PREFIX - Simplify Makefile PR: ports/189191 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Notes
Notes: svn path=/head/; revision=352798
Diffstat (limited to 'security/p5-PGP-Sign')
-rw-r--r--security/p5-PGP-Sign/Makefile63
1 files changed, 16 insertions, 47 deletions
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index c85d86d5b8e6..72eaf0318d1a 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -3,65 +3,34 @@
PORTNAME= PGP-Sign
PORTVERSION= 0.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= 5u623l20@gmail.com
COMMENT= Create detached PGP signatures for data
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
USES= perl5
USE_PERL5= configure
-CONFIGURE_ARGS= PGPS=${PGPS} PGPV=${PGPV} PGPSTYLE=${PGPSTYLE}
+CONFIGURE_ARGS= PGP=${PGP} PGPSTYLE=${PGPSTYLE}
-# If DEFAULTPGP isn't defined, it gets set to PGP2. If you don't like
-# the values that this process assigns to PGP (or PGPV and PGPS) and
-# PGPSTYLE, they can be predefined.
-#
# Currently useful values for DEFAULTPGP are:
# PGP2 - PGP 2.6.* or a reasonable facsimile thereof
-# PGP5 - PGP 5 or a work-alike
# GPG - Gnu Privacy Guard
-.ifndef DEFAULTPGP
-DEFAULTPGP= GPG
-.endif
-
-.if (${DEFAULTPGP} == PGP2 )
-BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
-RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
-PGPSTYLE?= PGP2
-.ifndef PGP
-PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
-.endif
-.elif (${DEFAULTPGP} == PGP5 )
-BUILD_DEPENDS= pgps:${PORTSDIR}/security/pgp5
-RUN_DEPENDS= pgps:${PORTSDIR}/security/pgp5
-PGPSTYLE?= PGP5
-.ifndef PGPS
-PGPS!= which pgps || ${ECHO} ${PREFIX}/bin/pgps
-.endif
-.ifndef PGPV
-PGPV!= which pgpv || ${ECHO} ${PREFIX}/bin/pgpv
-.endif
-.ifndef PGP
-PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
-.endif
-.elif (${DEFAULTPGP} == GPG)
-BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-PGPSTYLE?= GPG
-.ifndef PGP
-PGP!= which gpg || ${ECHO} ${PREFIX}/bin/gpg
-.endif
-.else
-.error Unsupported DEFAULTPGP value. See the Makefile for a list of acceptable values.
-.endif
-
-.ifdef PGP
-PGPS?= ${PGP}
-PGPV?= ${PGP}
-.endif
+OPTIONS_SINGLE= DEFAULTPGP
+OPTIONS_SINGLE_DEFAULTPGP= GNUPG PGP2
+OPTIONS_DEFAULT= GNUPG
+PGP2_DESC= PGP2 support
+GNUPG_BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+GNUPG_CONFIGURE_ON= PGP=${LOCALBASE}/bin/gpg PGPSTYLE=GPG
+GNUPG_RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+PGP2_BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
+PGP2_CONFIGURE_ON= PGP=${LOCALBASE}/bin/pgp PGPSTYLE=PGP2
+PGP2_RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
.include <bsd.port.mk>