aboutsummaryrefslogtreecommitdiff
path: root/security/p5-PGP-Sign
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-19 04:00:35 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-19 04:00:35 +0000
commitbb451e3b5bd208c0f28939e510e8b9538bc4b834 (patch)
treec364e279b6911e943d5e141babdead7dc2a8b0fe /security/p5-PGP-Sign
parent9fdab507a91a4b5a0b9ea6ca91694079f4b53fc3 (diff)
downloadports-bb451e3b5bd208c0f28939e510e8b9538bc4b834.tar.gz
ports-bb451e3b5bd208c0f28939e510e8b9538bc4b834.zip
Update to version 0.14.
PR: 11125 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=17990
Diffstat (limited to 'security/p5-PGP-Sign')
-rw-r--r--security/p5-PGP-Sign/Makefile54
-rw-r--r--security/p5-PGP-Sign/distinfo2
-rw-r--r--security/p5-PGP-Sign/pkg-descr2
3 files changed, 46 insertions, 12 deletions
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index 4769184a7d29..cc7ff9734e8f 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -1,34 +1,66 @@
# New ports collection makefile for: p5-PGP-Sign
-# Version required: 0.13
+# Version required: 0.14
# Date created: January 2, 1998
# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
#
-# $Id: Makefile,v 1.4 1998/09/15 21:31:53 asami Exp $
+# $Id: Makefile,v 1.5 1998/12/07 17:33:32 billf Exp $
#
-DISTNAME= PGP-Sign-0.13
-PKGNAME= p5-PGP-Sign-0.13
+DISTNAME= PGP-Sign-0.14
+PKGNAME= p5-PGP-Sign-0.14
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= PGP
MAINTAINER= croyle@gelemna.ft-wayne.in.us
-RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
-
USE_PERL5= yes
MAN3= PGP::Sign.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-# This module only works with version 2, so you need to set this
-# variable on the command line if you have something else installed as
-# pgp.
+# You can either define one of these on the command line or accept the
+# default (USE_PGP2). You can also predefine the values for PGP (or
+# PGPS and PGPV) and PGPSTYLE if you don't like what this makefile
+# would assign.
+# USE_PGP2 - use PGP 2.6.* or a reasonable facsimile thereof
+# USE_PGP5 - use PGP 5 or a work-alike
+# USE_GPG - use Gnu Privacy Guard
+
+.if !defined(USE_PGP5) && !defined(USE_GPG)
+USE_PGP2?= yes
+RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
.ifndef PGP
-PGP!= which pgp || echo ${PREFIX}/bin/pgp
+PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
+.endif
+PGPSTYLE?= PGP2
+.else
+.ifdef USE_PGP5
+RUN_DEPENDS= pgps:${PORTSDIR}/security/pgp5
+.ifndef PGPS
+PGPS!= which pgps || ${ECHO} ${PREFIX}/bin/pgps
+.endif
+.ifndef PGPV
+PGPV!= which pgpv || ${ECHO} ${PREFIX}/bin/pgpv
+.endif
+PGPSTYLE?= PGP5
+.endif
+.ifdef USE_GPG
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+.ifndef PGP
+PGP!= which gpg || ${ECHO} ${PREFIX}/bin/gpg
+.endif
+PGPSTYLE?= GPG
+.endif
+.endif
+
+.ifdef PGP
+PGPS= ${PGP}
+PGPV= ${PGP}
.endif
+CONFIG_ARGS= PGPS=${PGPS} PGPV=${PGPV} PGPSTYLE=${PGPSTYLE}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PGP=${PGP}
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL ${CONFIG_ARGS}
.include <bsd.port.mk>
diff --git a/security/p5-PGP-Sign/distinfo b/security/p5-PGP-Sign/distinfo
index fc92e5e2ff9f..2f0da21d4177 100644
--- a/security/p5-PGP-Sign/distinfo
+++ b/security/p5-PGP-Sign/distinfo
@@ -1 +1 @@
-MD5 (PGP-Sign-0.13.tar.gz) = 7c8c62b2916122989e748020cd566c12
+MD5 (PGP-Sign-0.14.tar.gz) = 68907baf0ff8fde87a4edabb973ba253
diff --git a/security/p5-PGP-Sign/pkg-descr b/security/p5-PGP-Sign/pkg-descr
index 19ef0531dd37..5aaea410118d 100644
--- a/security/p5-PGP-Sign/pkg-descr
+++ b/security/p5-PGP-Sign/pkg-descr
@@ -1,3 +1,5 @@
PGP::Sign is a special purpose module designed to create and check
detached signatures for data. It's mainly intended to be used for
things like reimplementing PGPMoose, signcontrol and pgpverify.
+
+It can use PGP 2.6.*, PGP 5 or Gnu Privacy Guard.