aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Protocol-ACME
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-11 15:48:48 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-11 15:48:48 +0000
commit8c945941d80c8df243b2f3cf01c4e1b61601b4fb (patch)
treeeddd46482b28d514cf1f89d3eeaeb0ab7d125468 /security/p5-Protocol-ACME
parenteb724048d8a6c02d57894d5ede90d55854491b6c (diff)
downloadports-8c945941d80c8df243b2f3cf01c4e1b61601b4fb.tar.gz
ports-8c945941d80c8df243b2f3cf01c4e1b61601b4fb.zip
New ports: security/ p5-Crypt-Format p5-Crypt-RSA-Parse p5-Protocol-ACME
Conversion utilities for encryption applications WWW: http://search.cpan.org/dist/Crypt-Format/ Parse RSA keys for useful information WWW: http://search.cpan.org/dist/Crypt-RSA-Parse/ Interface to the Let's Encrypt ACME API WWW: http://search.cpan.org/dist/Protocol-ACME/
Notes
Notes: svn path=/head/; revision=413040
Diffstat (limited to 'security/p5-Protocol-ACME')
-rw-r--r--security/p5-Protocol-ACME/Makefile27
-rw-r--r--security/p5-Protocol-ACME/distinfo2
-rw-r--r--security/p5-Protocol-ACME/pkg-descr3
-rw-r--r--security/p5-Protocol-ACME/pkg-plist19
4 files changed, 51 insertions, 0 deletions
diff --git a/security/p5-Protocol-ACME/Makefile b/security/p5-Protocol-ACME/Makefile
new file mode 100644
index 000000000000..7d5cce1003d0
--- /dev/null
+++ b/security/p5-Protocol-ACME/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= Protocol-ACME
+PORTVERSION= 0.11
+DISTVERSIONPREFIX=v
+CATEGORIES= security perl5
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Interface to the Let's Encrypt ACME API
+
+LICENSE= ART20
+
+RUN_DEPENDS= p5-Crypt-Format>=0.06:security/p5-Crypt-Format \
+ p5-Crypt-OpenSSL-Bignum>=0.06:security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-RSA>=0.28:security/p5-Crypt-OpenSSL-RSA \
+ p5-Digest-SHA>=5.95:security/p5-Digest-SHA \
+ p5-Log-Any>=1.032:devel/p5-Log-Any \
+ p5-JSON>=2.90:converters/p5-JSON \
+ p5-libwww>=6.13:www/p5-libwww
+
+USES= perl5
+USE_GITHUB= yes
+GH_ACCOUNT= sludin
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Protocol-ACME/distinfo b/security/p5-Protocol-ACME/distinfo
new file mode 100644
index 000000000000..45d92e66b13a
--- /dev/null
+++ b/security/p5-Protocol-ACME/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sludin-Protocol-ACME-v0.11_GH0.tar.gz) = 32c0cd807c6480ff96b926ed07bd755afbfcd5034b78a6ed839aa1e4fb316f5a
+SIZE (sludin-Protocol-ACME-v0.11_GH0.tar.gz) = 27545
diff --git a/security/p5-Protocol-ACME/pkg-descr b/security/p5-Protocol-ACME/pkg-descr
new file mode 100644
index 000000000000..e6d891fe476a
--- /dev/null
+++ b/security/p5-Protocol-ACME/pkg-descr
@@ -0,0 +1,3 @@
+Interface to the Let's Encrypt ACME API
+
+WWW: http://search.cpan.org/dist/Protocol-ACME/
diff --git a/security/p5-Protocol-ACME/pkg-plist b/security/p5-Protocol-ACME/pkg-plist
new file mode 100644
index 000000000000..499283711237
--- /dev/null
+++ b/security/p5-Protocol-ACME/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/Protocol/ACME.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge/LocalFile.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge/Manual.pm
+%%SITE_PERL%%/Protocol/ACME/Challenge/SimpleSSH.pm
+%%SITE_PERL%%/Protocol/ACME/Exception.pm
+%%SITE_PERL%%/Protocol/ACME/Key.pm
+%%SITE_PERL%%/Protocol/ACME/Logger.pm
+%%SITE_PERL%%/Protocol/ACME/OpenSSL.pm
+%%SITE_PERL%%/Protocol/ACME/Utils.pm
+%%SITE_PERL%%/Protocol/README.pod
+%%SITE_PERL%%/Protocol/client.pl
+%%SITE_PERL%%/Protocol/revoke.pl
+%%PERL5_MAN3%%/Protocol::ACME.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge::LocalFile.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge::Manual.3.gz
+%%PERL5_MAN3%%/Protocol::ACME::Challenge::SimpleSSH.3.gz
+%%PERL5_MAN3%%/Protocol::README.3.gz