aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Session-Token
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-27 21:21:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-27 21:21:54 +0000
commitbef55936cf0bf7253a625475ef46f5f36b11e99f (patch)
tree5d745ece224a1d14df9f8c7e7142e94663b86535 /security/p5-Session-Token
parent033203568b990d5b7989748f85524443c6167195 (diff)
downloadports-bef55936cf0bf7253a625475ef46f5f36b11e99f.tar.gz
ports-bef55936cf0bf7253a625475ef46f5f36b11e99f.zip
This module provides a secure, efficient, and simple interface for
creating session tokens, password reset codes, temporary passwords, random identifiers, and anything else you can think of. Like this: my $token = Session::Token->new->get; # 128 bits WWW: http://search.cpan.org/dist/Session-Token/ PR: 200390 Submitted by: hvo.pm@xs4all.nl
Notes
Notes: svn path=/head/; revision=387680
Diffstat (limited to 'security/p5-Session-Token')
-rw-r--r--security/p5-Session-Token/Makefile25
-rw-r--r--security/p5-Session-Token/distinfo2
-rw-r--r--security/p5-Session-Token/pkg-descr7
-rw-r--r--security/p5-Session-Token/pkg-plist3
4 files changed, 37 insertions, 0 deletions
diff --git a/security/p5-Session-Token/Makefile b/security/p5-Session-Token/Makefile
new file mode 100644
index 000000000000..0b8494ddeb98
--- /dev/null
+++ b/security/p5-Session-Token/Makefile
@@ -0,0 +1,25 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Session-Token
+PORTVERSION= 1.008
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:FRACTAL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Secure, efficient, simple random session token generation
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Session/Token/Token.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Session/Token/Token.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Session/Token/Token.so
+
+.include <bsd.port.mk>
diff --git a/security/p5-Session-Token/distinfo b/security/p5-Session-Token/distinfo
new file mode 100644
index 000000000000..9250b2743854
--- /dev/null
+++ b/security/p5-Session-Token/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Session-Token-1.008.tar.gz) = 80a8e2c4a97b2d712990052bdc2bf70c489171f1bf88f8e0ba5f58d7e1c2a3f8
+SIZE (Session-Token-1.008.tar.gz) = 21732
diff --git a/security/p5-Session-Token/pkg-descr b/security/p5-Session-Token/pkg-descr
new file mode 100644
index 000000000000..231c77051a5c
--- /dev/null
+++ b/security/p5-Session-Token/pkg-descr
@@ -0,0 +1,7 @@
+This module provides a secure, efficient, and simple interface for
+creating session tokens, password reset codes, temporary passwords,
+random identifiers, and anything else you can think of.
+
+Like this: my $token = Session::Token->new->get; # 128 bits
+
+WWW: http://search.cpan.org/dist/Session-Token/
diff --git a/security/p5-Session-Token/pkg-plist b/security/p5-Session-Token/pkg-plist
new file mode 100644
index 000000000000..ae5de6d715ad
--- /dev/null
+++ b/security/p5-Session-Token/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_ARCH%%/Session/Token.pm
+%%SITE_ARCH%%/auto/Session/Token/Token.so
+%%PERL5_MAN3%%/Session::Token.3.gz