aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Sudo
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-07-02 01:00:27 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-07-02 01:00:27 +0000
commitb399e0595ad5a123562574ca94e686bd7148d97c (patch)
tree227c43a30f67f66dd1b030bcbe1a4504c9fadb77 /security/p5-Sudo
parentc94ba61603f7e6aa7fbbb8f7b4aca58cf5e646b9 (diff)
downloadports-b399e0595ad5a123562574ca94e686bd7148d97c.tar.gz
ports-b399e0595ad5a123562574ca94e686bd7148d97c.zip
Add p5-Sudo 0.31, perl extension for running a command line sudo.
PR: ports/113056 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=194588
Diffstat (limited to 'security/p5-Sudo')
-rw-r--r--security/p5-Sudo/Makefile33
-rw-r--r--security/p5-Sudo/distinfo3
-rw-r--r--security/p5-Sudo/pkg-descr10
-rw-r--r--security/p5-Sudo/pkg-plist4
4 files changed, 50 insertions, 0 deletions
diff --git a/security/p5-Sudo/Makefile b/security/p5-Sudo/Makefile
new file mode 100644
index 000000000000..9fe0624b0931
--- /dev/null
+++ b/security/p5-Sudo/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Sudo
+# Date created: 2007-05-27
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sudo
+PORTVERSION= 0.31
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/L/LA/LANDMAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for running a command line sudo
+
+RUN_DEPENDS= ${SITE_PERL}/Term/ReadPassword.pm:${PORTSDIR}/devel/p5-Term-ReadPassword \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sudo.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires Perl >= 5.8.1. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Sudo/distinfo b/security/p5-Sudo/distinfo
new file mode 100644
index 000000000000..870b9a047a91
--- /dev/null
+++ b/security/p5-Sudo/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sudo-0.31.tar.gz) = 34474b59f70a266ca6060e0d3ffa6a9a
+SHA256 (Sudo-0.31.tar.gz) = 8450e60999a17137c7d52a1d2fe72fd51b320345f861e26ea4f0aa530359b205
+SIZE (Sudo-0.31.tar.gz) = 6822
diff --git a/security/p5-Sudo/pkg-descr b/security/p5-Sudo/pkg-descr
new file mode 100644
index 000000000000..68c6e81642ca
--- /dev/null
+++ b/security/p5-Sudo/pkg-descr
@@ -0,0 +1,10 @@
+Sudo runs commands as another user, provided the system sudo
+implementation is setup to enable this. This does not allow running
+applications securely, simply it allows the programmer to run a
+program as another user (suid) using the sudo tools rather than
+suidperl. Suidperl is not generally recommended for secure operation
+as another user. While sudo itself is a single point tool to enable
+one user to execute commands as another sudo does not itself make you
+any more or less secure.
+
+WWW: http://search.cpan.org/dist/Sudo
diff --git a/security/p5-Sudo/pkg-plist b/security/p5-Sudo/pkg-plist
new file mode 100644
index 000000000000..a1c52700c756
--- /dev/null
+++ b/security/p5-Sudo/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sudo/.packlist
+%%SITE_PERL%%/Sudo.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sudo