aboutsummaryrefslogtreecommitdiff
path: root/security/pam-pgsql
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-02-05 02:10:07 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-02-05 02:10:07 +0000
commitef458af23529dd9ff22678d94d0c770d225482c8 (patch)
treeeaf0b3c27909f65fbce9ffdd6b675254f46d2250 /security/pam-pgsql
parent97a8737613c9e8a2fa6f06952b8dd96d47902efb (diff)
downloadports-ef458af23529dd9ff22678d94d0c770d225482c8.tar.gz
ports-ef458af23529dd9ff22678d94d0c770d225482c8.zip
Fix the patch (a header and an empty line) and remove last mentions
of the shortlived pqescape.c.
Notes
Notes: svn path=/head/; revision=54220
Diffstat (limited to 'security/pam-pgsql')
-rw-r--r--security/pam-pgsql/files/Makefile.bsd3
-rw-r--r--security/pam-pgsql/files/patch-md56
2 files changed, 4 insertions, 5 deletions
diff --git a/security/pam-pgsql/files/Makefile.bsd b/security/pam-pgsql/files/Makefile.bsd
index cef112fc21d8..7b81d92454d0 100644
--- a/security/pam-pgsql/files/Makefile.bsd
+++ b/security/pam-pgsql/files/Makefile.bsd
@@ -2,8 +2,7 @@
.PATH: ${FILESDIR}
-SRCS= pam_pgsql.c pam_get_pass.c pam_std_option.c pam_get_service.c \
- pqescape.c
+SRCS= pam_pgsql.c pam_get_pass.c pam_std_option.c pam_get_service.c
LIB= pam_pgsql
SHLIB_NAME=${LIB}.so
diff --git a/security/pam-pgsql/files/patch-md5 b/security/pam-pgsql/files/patch-md5
index c68fa892c3ff..177c2696cd2b 100644
--- a/security/pam-pgsql/files/patch-md5
+++ b/security/pam-pgsql/files/patch-md5
@@ -3,7 +3,7 @@ greatly simplifying things...
--- pam_pgsql.c Wed Apr 18 16:47:57 2001
+++ pam_pgsql.c Wed Jan 9 14:46:01 2002
-@@ -14,5 +14,7 @@
+@@ -14,6 +14,7 @@
#include <syslog.h>
#include <ctype.h>
-#include <mhash.h>
@@ -12,6 +12,7 @@ greatly simplifying things...
+#include <md5.h>
#include <time.h>
#include <libpq-fe.h>
+-#include <crypt.h>
@@ -336,32 +336,7 @@
s = strdup(crypt(pass, crypt_make_salt()));
break;
@@ -48,7 +49,7 @@ greatly simplifying things...
+ break;
case PW_CLEAR:
default:
-@@ -416,35 +391,15 @@
+@@ -416,34 +391,15 @@
}
break;
- case PW_MD5: {
@@ -77,7 +78,6 @@ greatly simplifying things...
-
- if(strcmp(buf, stored_pw) == 0)
- rc = PAM_SUCCESS;
--
- free(buf);
- }
- }