aboutsummaryrefslogtreecommitdiff
path: root/security/pam_ocra
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
commit5b55a8a53e383d5e641472b56a6d631e59da3967 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /security/pam_ocra
parent769a9f1570ce818b49b6170bf5745363ffbe79e0 (diff)
downloadports-5b55a8a53e383d5e641472b56a6d631e59da3967.tar.gz
ports-5b55a8a53e383d5e641472b56a6d631e59da3967.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Notes
Notes: svn path=/head/; revision=416966
Diffstat (limited to 'security/pam_ocra')
-rw-r--r--security/pam_ocra/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/security/pam_ocra/Makefile b/security/pam_ocra/Makefile
index e5756951b815..22134d709612 100644
--- a/security/pam_ocra/Makefile
+++ b/security/pam_ocra/Makefile
@@ -11,6 +11,7 @@ COMMENT= RFC6287 (OCRA) PAM module
LICENSE= BSD2CLAUSE
USES= uidfix
+USE_OPENSSL= yes
USE_GITHUB= yes
@@ -22,7 +23,7 @@ PLIST_FILES= lib/pam_ocra.so \
man/man8/pam_ocra.8.gz \
man/man8/ocra_tool.8.gz
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000015
WITH_OPENSSL_PORT= yes
@@ -30,10 +31,4 @@ CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
.endif
-# we need to .include bsd.openssl.mk manually here.because USE_OPENSSL only
-# works when it is defined before bsd.port{.pre}.mk is .included.
-# This makes it currently impossible to combine this macro with OSVERSION to
-# conditionally select WITH_OPENSSL_PORT for OSVERSIONS before 1000015.
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>