aboutsummaryrefslogtreecommitdiff
path: root/security/pam_p11
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2018-10-16 10:30:43 +0000
committerAlex Dupre <ale@FreeBSD.org>2018-10-16 10:30:43 +0000
commitb4d7975e431a5100df09294fe413834f17d1e52a (patch)
tree73bf557f427a5fff9aa9ee29b9434f91b91dcd3f /security/pam_p11
parent622b763a1c81b01c670d53bae0370b25922e7f91 (diff)
downloadports-b4d7975e431a5100df09294fe413834f17d1e52a.tar.gz
ports-b4d7975e431a5100df09294fe413834f17d1e52a.zip
Update to 0.2.0 release.
Notes
Notes: svn path=/head/; revision=482217
Diffstat (limited to 'security/pam_p11')
-rw-r--r--security/pam_p11/Makefile17
-rw-r--r--security/pam_p11/distinfo5
-rw-r--r--security/pam_p11/files/patch-configure20
-rw-r--r--security/pam_p11/files/patch-src_Makefile.in15
-rw-r--r--security/pam_p11/files/patch-src_pam__p11.c11
-rw-r--r--security/pam_p11/files/patch-src_pam_p11.c11
-rw-r--r--security/pam_p11/files/patch-src_test.c21
-rw-r--r--security/pam_p11/pkg-descr2
-rw-r--r--security/pam_p11/pkg-plist2
9 files changed, 55 insertions, 49 deletions
diff --git a/security/pam_p11/Makefile b/security/pam_p11/Makefile
index f48ea218f706..f5cff011519a 100644
--- a/security/pam_p11/Makefile
+++ b/security/pam_p11/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= pam_p11
-PORTVERSION= 0.1.5
-PORTREVISION= 3
+PORTVERSION= 0.2.0
CATEGORIES= security
-MASTER_SITES= SF/opensc/${PORTNAME}
+MASTER_SITES= https://github.com/OpenSC/pam_p11/releases/download/pam_p11-${PORTVERSION}/
MAINTAINER= ale@FreeBSD.org
COMMENT= PAM module using crypto tokens for auth
@@ -14,20 +13,20 @@ LICENSE= LGPL21
LIB_DEPENDS= libp11.so:security/libp11
+USES= libtool pkgconfig ssl
+
OPTIONS_DEFINE= DOCS
GNU_CONFIGURE= yes
-USES= libtool pkgconfig ssl
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
+
+PLIST_FILES= lib/security/pam_p11.so
PORTDOCS= *
post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/wiki
- @(cd ${WRKSRC} && ${CP} NEWS ${STAGEDIR}${DOCSDIR})
- @(cd ${WRKSRC}/doc && ${CP} README ${STAGEDIR}${DOCSDIR})
- @(cd ${WRKSRC}/doc && ${CP} *.css *.html ${STAGEDIR}${DOCSDIR}/wiki)
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/pam_p11/distinfo b/security/pam_p11/distinfo
index 2e527b575113..2571491a97d2 100644
--- a/security/pam_p11/distinfo
+++ b/security/pam_p11/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pam_p11-0.1.5.tar.gz) = 74da875467c4ba156f7cb7eaec0718f92dded03f40db3c6c0423c03f44d9f25a
-SIZE (pam_p11-0.1.5.tar.gz) = 348181
+TIMESTAMP = 1539433560
+SHA256 (pam_p11-0.2.0.tar.gz) = 088d4c05d23fee9535f1b16f6c993c88b11cbed0288d5a1d0b37da2f390325a2
+SIZE (pam_p11-0.2.0.tar.gz) = 417550
diff --git a/security/pam_p11/files/patch-configure b/security/pam_p11/files/patch-configure
deleted file mode 100644
index dc08d1710120..000000000000
--- a/security/pam_p11/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig Thu Jun 1 15:05:28 2006
-+++ configure Thu Jun 1 15:07:47 2006
-@@ -20823,7 +20823,7 @@
- (exit $ac_status); }; then
- pkg_cv_OPENSSL_CFLAGS=`$PKG_CONFIG --cflags "openssl" 2>/dev/null`
- else
-- pkg_failed=yes
-+ pkg_cv_OPENSSL_CFLAGS=$ac_cv_env_OPENSSL_CFLAGS_value
- fi
- else
- pkg_failed=untried
-@@ -20837,7 +20837,7 @@
- (exit $ac_status); }; then
- pkg_cv_OPENSSL_LIBS=`$PKG_CONFIG --libs "openssl" 2>/dev/null`
- else
-- pkg_failed=yes
-+ pkg_cv_OPENSSL_LIBS=$ac_cv_env_OPENSSL_LIBS_value
- fi
- else
- pkg_failed=untried
diff --git a/security/pam_p11/files/patch-src_Makefile.in b/security/pam_p11/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..837c9f415d91
--- /dev/null
+++ b/security/pam_p11/files/patch-src_Makefile.in
@@ -0,0 +1,15 @@
+--- src/Makefile.in.orig 2018-10-16 10:16:04 UTC
++++ src/Makefile.in
+@@ -384,10 +384,10 @@ pam_p11_la_SOURCES = pam_p11.c base64.c
+ pam_p11.exports
+
+ test_login_SOURCES = test.c login.c $(pam_p11_la_SOURCES)
+-test_login_LDADD = -lpam_misc
++test_login_LDADD =
+ test_login_CFLAGS = $(AM_CFLAGS) -DLIBDIR=\"$(libdir)\" -DTEST
+ test_passwd_SOURCES = test.c passwd.c $(pam_p11_la_SOURCES)
+-test_passwd_LDADD = -lpam_misc
++test_passwd_LDADD =
+ test_passwd_CFLAGS = $(AM_CFLAGS) -DLIBDIR=\"$(libdir)\" -DTEST
+ all: all-am
+
diff --git a/security/pam_p11/files/patch-src_pam__p11.c b/security/pam_p11/files/patch-src_pam__p11.c
new file mode 100644
index 000000000000..15a67fd361fc
--- /dev/null
+++ b/security/pam_p11/files/patch-src_pam__p11.c
@@ -0,0 +1,11 @@
+--- src/pam_p11.c.orig 2018-10-16 10:00:15 UTC
++++ src/pam_p11.c
+@@ -53,7 +53,7 @@
+ #include <security/pam_ext.h>
+ #else
+ #define pam_syslog(handle, level, msg...) syslog(level, ## msg)
+-static int pam_vprompt(pam_handle_t *pamh, int style, char **response,
++int pam_vprompt(const pam_handle_t *pamh, int style, char **response,
+ const char *fmt, va_list args)
+ {
+ int r = PAM_CRED_INSUFFICIENT;
diff --git a/security/pam_p11/files/patch-src_pam_p11.c b/security/pam_p11/files/patch-src_pam_p11.c
deleted file mode 100644
index ede503eea94a..000000000000
--- a/security/pam_p11/files/patch-src_pam_p11.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/pam_p11.c.orig Sun Jun 11 21:16:46 2006
-+++ src/pam_p11.c Sun Jun 11 21:17:53 2006
-@@ -39,7 +39,7 @@
- #define LOGNAME "pam_p11" /* name for log-file entries */
-
- #define RANDOM_SOURCE "/dev/urandom"
--#define RANDOM_SIZE 128
-+#define RANDOM_SIZE 20
- #define MAX_SIGSIZE 256
-
- extern int match_user(X509 * x509, const char *login);
diff --git a/security/pam_p11/files/patch-src_test.c b/security/pam_p11/files/patch-src_test.c
index 6cfa47b33520..637fe423794e 100644
--- a/security/pam_p11/files/patch-src_test.c
+++ b/security/pam_p11/files/patch-src_test.c
@@ -1,10 +1,23 @@
---- src/test.c.orig 2008-08-26 12:37:37.000000000 +0200
-+++ src/test.c 2008-08-26 12:37:45.000000000 +0200
-@@ -2,7 +2,6 @@
+--- src/test.c.orig 2018-05-04 14:52:04 UTC
++++ src/test.c
+@@ -22,9 +22,10 @@
+
+ #include <stdio.h>
#include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
#include <security/pam_appl.h>
-#include <security/pam_misc.h>
#include <security/pam_modules.h>
- int main(int argc, char **argv)
+ #ifndef LIBDIR
+@@ -42,7 +43,7 @@ int main(int argc, const char **argv)
+ };
+ pam_handle_t *pamh = NULL;
+ struct pam_conv conv = {
+- misc_conv,
++ openpam_ttyconv,
+ NULL,
+ };
+ int r;
diff --git a/security/pam_p11/pkg-descr b/security/pam_p11/pkg-descr
index 524e86515faa..6a654ad9c21c 100644
--- a/security/pam_p11/pkg-descr
+++ b/security/pam_p11/pkg-descr
@@ -18,4 +18,4 @@ certificate chains, certificate authorities, revocation
lists or OCSP. Perfect for the small installation with no
frills.
-WWW: https://github.com/OpenSC/OpenSC/wiki/pam_p11-simple-RSA-authentication-with-PKCS%2311-modules
+WWW: https://github.com/OpenSC/pam_p11
diff --git a/security/pam_p11/pkg-plist b/security/pam_p11/pkg-plist
deleted file mode 100644
index a609397fb98c..000000000000
--- a/security/pam_p11/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/security/pam_p11_opensc.so
-lib/security/pam_p11_openssh.so