aboutsummaryrefslogtreecommitdiff
path: root/security/pam_ssh_agent_auth
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-26 12:23:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-26 12:23:45 +0000
commit79a8d8d1baf860c3d4f183aa83f14c7546902343 (patch)
treefca1e99925f07531eaf93bf240bfb0744661b467 /security/pam_ssh_agent_auth
parent5834d0a6f8597f80d80ab4dc2ff237fb0e6c5fab (diff)
downloadports-79a8d8d1baf860c3d4f183aa83f14c7546902343.tar.gz
ports-79a8d8d1baf860c3d4f183aa83f14c7546902343.zip
PAM module which permits authentication for arbitrary services via
ssh-agent. Written with sudo in mind, but like any auth PAM module, can be used for for many purposes. WWW: http://pamsshagentauth.sourceforge.net/
Notes
Notes: svn path=/head/; revision=246705
Diffstat (limited to 'security/pam_ssh_agent_auth')
-rw-r--r--security/pam_ssh_agent_auth/Makefile24
-rw-r--r--security/pam_ssh_agent_auth/distinfo3
-rw-r--r--security/pam_ssh_agent_auth/files/patch-Makefile.in20
-rw-r--r--security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c13
-rw-r--r--security/pam_ssh_agent_auth/pkg-descr5
5 files changed, 65 insertions, 0 deletions
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
new file mode 100644
index 000000000000..91fd8c0c915a
--- /dev/null
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pam_ssh_agent_auth
+# Date created: 26 December 2009
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_ssh_agent_auth
+PORTVERSION= 0.9.1
+CATEGORIES= security
+MASTER_SITES= SF/pamsshagentauth/${PORTNAME}/v${PORTVERSION}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= PAM module which permits authentication via ssh-agent
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --libexecdir=${LOCALBASE}/lib
+USE_PERL5= yes
+
+MAN8= pam_ssh_agent_auth.8
+PLIST_FILES= lib/pam_ssh_agent_auth.so
+
+.include <bsd.port.mk>
diff --git a/security/pam_ssh_agent_auth/distinfo b/security/pam_ssh_agent_auth/distinfo
new file mode 100644
index 000000000000..1604719cc1f5
--- /dev/null
+++ b/security/pam_ssh_agent_auth/distinfo
@@ -0,0 +1,3 @@
+MD5 (pam_ssh_agent_auth-0.9.1.tar.bz2) = b6e10c8cdf58075d1681e76e39431311
+SHA256 (pam_ssh_agent_auth-0.9.1.tar.bz2) = 2f502ccc7ae93a9c491c08ad314fe33e2a5296ad33b8b8d06e5b31deb19d465e
+SIZE (pam_ssh_agent_auth-0.9.1.tar.bz2) = 244188
diff --git a/security/pam_ssh_agent_auth/files/patch-Makefile.in b/security/pam_ssh_agent_auth/files/patch-Makefile.in
new file mode 100644
index 000000000000..1ed36c400418
--- /dev/null
+++ b/security/pam_ssh_agent_auth/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig 2009-11-07 03:47:20.000000000 +0100
++++ Makefile.in 2009-12-26 12:53:16.000000000 +0100
+@@ -13,7 +13,7 @@
+ datadir=@datadir@
+ datarootdir=@datarootdir@
+ mandir=@mandir@
+-mansubdir=@mansubdir@
++mansubdir=man
+ sysconfdir=@sysconfdir@
+ piddir=@piddir@
+ srcdir=@srcdir@
+@@ -130,7 +130,7 @@
+
+ uninstall:
+ -rm -f $(DESTDIR)$(libexecdir)/pam_ssh_agent_auth.so
+- -rm -f $(DESTDIR)$(mandir)/$(mansubdir)8/$(mansubdir)8/pam_ssh_agent_auth.8
++ -rm -f $(DESTDIR)$(mandir)/$(mansubdir)8/pam_ssh_agent_auth.8
+
+ compat-tests: $(LIBCOMPAT)
+ (cd openbsd-compat/regress && $(MAKE))
diff --git a/security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c b/security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c
new file mode 100644
index 000000000000..50b976e20687
--- /dev/null
+++ b/security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c
@@ -0,0 +1,13 @@
+--- pam_user_authorized_keys.c.orig 2009-11-07 03:47:20.000000000 +0100
++++ pam_user_authorized_keys.c 2009-12-26 12:49:29.000000000 +0100
+@@ -81,6 +81,10 @@
+ extern uint8_t allow_user_owned_authorized_keys_file;
+ uid_t authorized_keys_file_allowed_owner_uid;
+
++#ifndef HOST_NAME_MAX
++#define HOST_NAME_MAX MAXHOSTNAMELEN
++#endif
++
+ void
+ parse_authorized_key_file(const char *user, const char *authorized_keys_file_input)
+ {
diff --git a/security/pam_ssh_agent_auth/pkg-descr b/security/pam_ssh_agent_auth/pkg-descr
new file mode 100644
index 000000000000..9cabfac61a54
--- /dev/null
+++ b/security/pam_ssh_agent_auth/pkg-descr
@@ -0,0 +1,5 @@
+PAM module which permits authentication for arbitrary services via
+ssh-agent. Written with sudo in mind, but like any auth PAM module,
+can be used for for many purposes.
+
+WWW: http://pamsshagentauth.sourceforge.net/