aboutsummaryrefslogtreecommitdiff
path: root/security/paperkey/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-27 12:00:24 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-27 12:00:24 +0000
commitbe5de261d4a48c4dc2b3ad0b4c02a05c99c86244 (patch)
tree00f015dfed14fd8432da16aedd5a282eb8707aec /security/paperkey/Makefile
parent1309964973f4ed252a01d8db81bea67008657f64 (diff)
downloadports-be5de261d4a48c4dc2b3ad0b4c02a05c99c86244.tar.gz
ports-be5de261d4a48c4dc2b3ad0b4c02a05c99c86244.zip
Notes
Diffstat (limited to 'security/paperkey/Makefile')
-rw-r--r--security/paperkey/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/security/paperkey/Makefile b/security/paperkey/Makefile
index f8a39cdfad0c..622bad68e8ba 100644
--- a/security/paperkey/Makefile
+++ b/security/paperkey/Makefile
@@ -14,16 +14,23 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-ALL_TARGET= all check
PLIST_FILES= bin/paperkey
MAN1= paperkey.1
PORTDOCS= NEWS README
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+# Setting ALL_TARGET to "all check" is racy and breaks parallel builds
+post-build:
+ ${MAKE} -C ${BUILD_WRKSRC} check
+
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
.endif
.include <bsd.port.mk>