aboutsummaryrefslogtreecommitdiff
path: root/security/pcsc-tools
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2012-01-20 13:03:48 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2012-01-20 13:03:48 +0000
commit425c7f03e2a4fcf64f40b5201810953846548015 (patch)
tree989901e1af8e55fc824d424265bb819ef4f8ad40 /security/pcsc-tools
parent41efa3cdf49c2009dd0c0d85f835a258c401a5fc (diff)
downloadports-425c7f03e2a4fcf64f40b5201810953846548015.tar.gz
ports-425c7f03e2a4fcf64f40b5201810953846548015.zip
Add pcsc-tools, tools for testing PCSC cards and readers
First submission: PR: 42702 Submitted by: bms
Notes
Notes: svn path=/head/; revision=289517
Diffstat (limited to 'security/pcsc-tools')
-rw-r--r--security/pcsc-tools/Makefile29
-rw-r--r--security/pcsc-tools/distinfo2
-rw-r--r--security/pcsc-tools/files/patch-Makefile21
-rw-r--r--security/pcsc-tools/pkg-descr4
-rw-r--r--security/pcsc-tools/pkg-plist6
5 files changed, 62 insertions, 0 deletions
diff --git a/security/pcsc-tools/Makefile b/security/pcsc-tools/Makefile
new file mode 100644
index 000000000000..e088e4e9dc33
--- /dev/null
+++ b/security/pcsc-tools/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pcsc-tools
+# Date created: 2012-01-20
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= pcsc-tools
+PORTVERSION= 1.4.18
+CATEGORIES= security
+MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/pcsc-tools/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Tools to test a PCSC driver, card or reader
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+RUN_DEPENDS= ${SITE_PERL}/$PERL_ARCH}/Chipcard/PCSC.pm:${PORTSDIR}/devel/p5-PCSC-Card
+
+USE_GMAKE= yes
+
+MAN1= pcsc_scan.1 gscriptor.1p scriptor.1p ATR_analysis.1p
+
+post-install:
+.for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/$i ${MAN1PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/security/pcsc-tools/distinfo b/security/pcsc-tools/distinfo
new file mode 100644
index 000000000000..0f4db4db6b68
--- /dev/null
+++ b/security/pcsc-tools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pcsc-tools-1.4.18.tar.gz) = 4f6cbd897205e9d714acdccdc3eb8e1804e907e79ecf2f52b272dba1195096ad
+SIZE (pcsc-tools-1.4.18.tar.gz) = 93764
diff --git a/security/pcsc-tools/files/patch-Makefile b/security/pcsc-tools/files/patch-Makefile
new file mode 100644
index 000000000000..d2eb1b9db691
--- /dev/null
+++ b/security/pcsc-tools/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.bak 2009-05-14 20:39:23.000000000 +0200
++++ Makefile 2012-01-20 13:44:11.000000000 +0100
+@@ -20,7 +20,7 @@
+ BIN_SCRIPT = ATR_analysis gscriptor scriptor
+ MAN = pcsc_scan.1.gz gscriptor.1p.gz scriptor.1p.gz ATR_analysis.1p.gz
+
+-all: $(BIN) $(MAN)
++all: $(BIN)
+
+ pcsc_scan: pcsc_scan.o
+
+@@ -33,9 +33,6 @@
+ install -d $(DESTDIR)/share/pcsc
+ install -m 644 smartcard_list.txt $(DESTDIR)/share/pcsc
+
+- install -d $(DESTDIR)/share/man/man1/
+- install -m 644 $(MAN) $(DESTDIR)/share/man/man1/
+-
+ clean:
+ rm -f pcsc_scan.o $(BIN) $(MAN)
+
diff --git a/security/pcsc-tools/pkg-descr b/security/pcsc-tools/pkg-descr
new file mode 100644
index 000000000000..f30145504943
--- /dev/null
+++ b/security/pcsc-tools/pkg-descr
@@ -0,0 +1,4 @@
+These tools are used to test a PC/SC driver, card or reader or send commands
+in a friendly environment (text or graphical user interface).
+
+WWW: http://ludovic.rousseau.free.fr/softwares/pcsc-tools/
diff --git a/security/pcsc-tools/pkg-plist b/security/pcsc-tools/pkg-plist
new file mode 100644
index 000000000000..16a5f31cec71
--- /dev/null
+++ b/security/pcsc-tools/pkg-plist
@@ -0,0 +1,6 @@
+bin/pcsc_scan
+bin/ATR_analysis
+bin/gscriptor
+bin/scriptor
+share/pcsc/smartcard_list.txt
+@dirrm share/pcsc