aboutsummaryrefslogtreecommitdiff
path: root/security/pear-File_Passwd
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-10 00:20:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-10 00:20:14 +0000
commit16c086f1c9b2624c39255e175e72a691150c85d4 (patch)
tree7527adb539eafab7b2a480fb2eeb179039f59540 /security/pear-File_Passwd
parent304ce225f6292b4f7f9123c74900adff9d7e149b (diff)
downloadports-16c086f1c9b2624c39255e175e72a691150c85d4.tar.gz
ports-16c086f1c9b2624c39255e175e72a691150c85d4.zip
Add pear-File_Passwd, class to manipulate and authenticate against standard Unix,
SMB server, AuthUser (.htpasswd), AuthDigest (.htdigest), CVS pserver and custom formatted password files. PR: ports/73716 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Notes
Notes: svn path=/head/; revision=121259
Diffstat (limited to 'security/pear-File_Passwd')
-rw-r--r--security/pear-File_Passwd/Makefile30
-rw-r--r--security/pear-File_Passwd/distinfo2
-rw-r--r--security/pear-File_Passwd/pkg-descr5
3 files changed, 37 insertions, 0 deletions
diff --git a/security/pear-File_Passwd/Makefile b/security/pear-File_Passwd/Makefile
new file mode 100644
index 000000000000..7d9f35fb9a8a
--- /dev/null
+++ b/security/pear-File_Passwd/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-File_Passwd
+# Date created: 09 November 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= File_Passwd
+PORTVERSION= 1.1.1
+CATEGORIES= security www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class to manipulate many kinds of password files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= File
+FILES= Passwd.php Passwd/Common.php Passwd/Unix.php Passwd/Cvs.php \
+ Passwd/Smb.php Passwd/Authbasic.php Passwd/Authdigest.php \
+ Passwd/Custom.php
+TESTS= testsuite.php test_file_passwd.php test_common.php test_unix.php \
+ test_smb.php test_cvs.php test_authbasic.php test_authdigest.php \
+ test_custom.php README.txt common.txt passwd.unix.txt \
+ passwd.cvs.txt passwd.smb.txt passwd.authbasic.txt \
+ passwd.authdigest.txt passwd.custom.txt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/security/pear-File_Passwd/distinfo b/security/pear-File_Passwd/distinfo
new file mode 100644
index 000000000000..03cbd2ed882f
--- /dev/null
+++ b/security/pear-File_Passwd/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/File_Passwd-1.1.1.tgz) = 55275a4affd6734d56aaa25b6a8f5821
+SIZE (PEAR/File_Passwd-1.1.1.tgz) = 23200
diff --git a/security/pear-File_Passwd/pkg-descr b/security/pear-File_Passwd/pkg-descr
new file mode 100644
index 000000000000..90b7d55cfda7
--- /dev/null
+++ b/security/pear-File_Passwd/pkg-descr
@@ -0,0 +1,5 @@
+Provides methods to manipulate and authenticate against standard Unix,
+SMB server, AuthUser (.htpasswd), AuthDigest (.htdigest), CVS pserver
+and custom formatted password files.
+
+WWW: http://pear.php.net/package/File_Passwd/