aboutsummaryrefslogtreecommitdiff
path: root/security/pear-LiveUser
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-16 23:59:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-16 23:59:23 +0000
commit23488656044dc184f357418fb42025bf898924ad (patch)
tree6018ee14177d5696070cc6271228742c192cdac6 /security/pear-LiveUser
parent68f1515194a9d627359abe61978276cc70421369 (diff)
downloadports-23488656044dc184f357418fb42025bf898924ad.tar.gz
ports-23488656044dc184f357418fb42025bf898924ad.zip
- Update to 0.15.0
- Fix dependencies - Remove PHP dependency check PR: ports/78890 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net> (maintainer)
Notes
Notes: svn path=/head/; revision=131456
Diffstat (limited to 'security/pear-LiveUser')
-rw-r--r--security/pear-LiveUser/Makefile47
-rw-r--r--security/pear-LiveUser/distinfo4
2 files changed, 22 insertions, 29 deletions
diff --git a/security/pear-LiveUser/Makefile b/security/pear-LiveUser/Makefile
index 0cdb6198315a..ade0cb5d85a6 100644
--- a/security/pear-LiveUser/Makefile
+++ b/security/pear-LiveUser/Makefile
@@ -6,19 +6,17 @@
#
PORTNAME= LiveUser
-PORTVERSION= 0.14.0
+PORTVERSION= 0.15.0
CATEGORIES= security www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR user authentication and permission management framework
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/Event/Dispatcher.php:${PORTSDIR}/devel/pear-Event_Dispatcher
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PHP= yes
-
LATEST_LINK= pear-LiveUser
-OPTIONS= PEAR_DB "PEAR::DB support" on \
+OPTIONS= PEAR_DB "PEAR::DB support" off \
PEAR_MDB "PEAR::MDB support" off \
PEAR_MDB2 "PEAR::MDB2 support" off \
PEAR_LOG "PEAR::Log support" off \
@@ -27,15 +25,15 @@ OPTIONS= PEAR_DB "PEAR::DB support" on \
CATEGORY= LiveUser
FILES= Auth/Common.php Auth/DB.php Auth/MDB.php Auth/MDB2.php \
- Auth/PEARAuth.php Auth/XML.php Perm/Complex.php Perm/Medium.php \
- Perm/Simple.php Perm/Storage.php Perm/Storage/Cache.php \
- Perm/Storage/DB.php Perm/Storage/MDB.php Perm/Storage/MDB2.php \
- Perm/Storage/SQL.php Perm/Storage/XML.php LiveUser.php
-SQLS= Auth_DB.sql auth_mdb_schema.xml Auth_XML.xml perm_db.sql \
- perm_db_complex.sql perm_db_medium.sql perm_db_simple.sql \
- perm_mdb_schema.xml Perm_XML.xml README
+ Auth/PEARAuth.php Auth/Session.php Auth/XML.php Perm/Complex.php \
+ Perm/Medium.php Perm/Simple.php Perm/Storage.php \
+ Perm/Storage/Cache.php Perm/Storage/DB.php Perm/Storage/Globals.php \
+ Perm/Storage/MDB.php Perm/Storage/MDB2.php Perm/Storage/SQL.php \
+ Perm/Storage/XML.php LiveUser.php
+SQLS= auth_mdb_schema.xml Auth_XML.xml install.php perm_mdb_schema.xml \
+ Perm_XML.xml README
DOCS= lgpl.txt
-EXAMPLES= README example1/Auth_XML.xml example1/conf.php example1/example.php \
+EXAMPLES= example1/Auth_XML.xml example1/conf.php example1/example.php \
example1/index.html example1/README example2/Auth_XML.xml \
example2/conf.php example2/example.php example2/index.html \
example2/Perm_XML.xml example2/README example4/Auth_XML.xml \
@@ -44,40 +42,35 @@ EXAMPLES= README example1/Auth_XML.xml example1/conf.php example1/example.php \
example4/loginform.tpl.php example4/news_change.php \
example4/news_change.tpl.php example4/news_new.php \
example4/news_new.tpl.php example4/news_notallowed.tpl.php \
- example4/news_view.php example4/news_view.tpl.php example4/style.css
+ example4/news_view.php example4/news_view.tpl.php example4/README \
+ example4/style.css
_EXAMPLESDIR= docs/examples
_DOCSDIR= .
.include <bsd.port.pre.mk>
-PHP_VERS= ${PHP_VERSION:S/.//g}
-
-.if defined(PHP_VERS) && ${PHP_VERS} < 420
-IGNORE= "You need PHP 4.2.0 or later to install PEAR::LiveUser"
-.endif
-
-.if !defined(WITHOUT_PEAR_DB)
-BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.if defined(WITH_PEAR_DB)
+RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
.endif
.if defined(WITH_PEAR_MDB)
-BUILD_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
.endif
.if defined(WITH_PEAR_MDB2)
-BUILD_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
.endif
.if defined(WITH_PEAR_LOG)
-BUILD_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
.endif
.if defined(WITH_PEAR_XML_TREE)
-BUILD_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
+RUN_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
.endif
.if defined(WITH_PEAR_CRYPT_RC4)
-BUILD_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
+RUN_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
.endif
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
diff --git a/security/pear-LiveUser/distinfo b/security/pear-LiveUser/distinfo
index 73943a1e9deb..5d2b253530d4 100644
--- a/security/pear-LiveUser/distinfo
+++ b/security/pear-LiveUser/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/LiveUser-0.14.0.tgz) = 14b46ee7c1a508d5ac1cbd9531fd0940
-SIZE (PEAR/LiveUser-0.14.0.tgz) = 64484
+MD5 (PEAR/LiveUser-0.15.0.tgz) = 29fc99fc591e3df5c2c86a4e5334a924
+SIZE (PEAR/LiveUser-0.15.0.tgz) = 63965