aboutsummaryrefslogtreecommitdiff
path: root/security/pecl-gnupg
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2010-01-20 00:37:04 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2010-01-20 00:37:04 +0000
commit9330f7454640033f9b87631d6f0e543454731494 (patch)
tree64fd2ea926693763a9ee94ab28f699530dfdf88f /security/pecl-gnupg
parent009c22a166080c627c8f47f511bd98b30e44795d (diff)
downloadports-9330f7454640033f9b87631d6f0e543454731494.tar.gz
ports-9330f7454640033f9b87631d6f0e543454731494.zip
- Fix segmantation fault with new gnupg
- Bump PORTREVISION PR: 142311 Submitted by: miwi
Notes
Notes: svn path=/head/; revision=248181
Diffstat (limited to 'security/pecl-gnupg')
-rw-r--r--security/pecl-gnupg/Makefile2
-rw-r--r--security/pecl-gnupg/files/patch-gnupg.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
index 5abdecd3b9bf..479f432687d5 100644
--- a/security/pecl-gnupg/Makefile
+++ b/security/pecl-gnupg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnupg
PORTVERSION= 1.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/security/pecl-gnupg/files/patch-gnupg.c b/security/pecl-gnupg/files/patch-gnupg.c
new file mode 100644
index 000000000000..9697f829a8ce
--- /dev/null
+++ b/security/pecl-gnupg/files/patch-gnupg.c
@@ -0,0 +1,13 @@
+#
+# http://www.freebsd.org/cgi/query-pr.cgi?pr=142311
+#
+--- gnupg.c.orig 2010-01-04 18:08:52.000000000 +0100
++++ gnupg.c 2010-01-04 18:09:14.000000000 +0100
+@@ -136,6 +136,7 @@
+ static void gnupg_res_init(gnupg_object *intern TSRMLS_DC){
+ /* init the gpgme-lib and set the default values */
+ gpgme_ctx_t ctx;
++ gpgme_check_version (0);
+ gpgme_new (&ctx);
+ gpgme_set_armor (ctx,1);
+ intern->ctx = ctx;