aboutsummaryrefslogtreecommitdiff
path: root/security/pecl-krb5
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2017-01-21 13:10:31 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2017-01-21 13:10:31 +0000
commit1ae118fdaab6dbb42644d1b7640934f5fe5c3d6c (patch)
tree0f990fe6d442421fc8120b689459a8ad6d8eb087 /security/pecl-krb5
parentfa3512e2a57d498390c78961e5d0a60ffeaafaec (diff)
downloadports-1ae118fdaab6dbb42644d1b7640934f5fe5c3d6c.tar.gz
ports-1ae118fdaab6dbb42644d1b7640934f5fe5c3d6c.zip
Add port of php kerberos
An interface for maintaining credential caches (KRB5CCache), that can be used for authenticating against a kerberos5 realm. Bindings for nearly the complete GSSAPI (RFC2744). The administrative interface (KADM5). Support for HTTP Negotiate authentication via GSSAPI. WWW: https://pecl.php.net/package/krb5
Notes
Notes: svn path=/head/; revision=432031
Diffstat (limited to 'security/pecl-krb5')
-rw-r--r--security/pecl-krb5/Makefile21
-rw-r--r--security/pecl-krb5/distinfo3
-rw-r--r--security/pecl-krb5/files/patch-krb5.c10
-rw-r--r--security/pecl-krb5/pkg-descr7
4 files changed, 41 insertions, 0 deletions
diff --git a/security/pecl-krb5/Makefile b/security/pecl-krb5/Makefile
new file mode 100644
index 000000000000..2cac4612ba81
--- /dev/null
+++ b/security/pecl-krb5/Makefile
@@ -0,0 +1,21 @@
+# Created by: girgen@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= krb5
+PORTVERSION= 1.1.1
+CATEGORIES= security pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+
+MAINTAINER= girgen@FreeBSD.org
+COMMENT= PECL classes for PAM integration
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libkrb5support.so:security/krb5
+
+USES= php:ext tar:tgz
+
+CONFIGURE_ARGS= --with-krb5config=${LOCALBASE}/bin/krb5-config
+
+.include <bsd.port.mk>
diff --git a/security/pecl-krb5/distinfo b/security/pecl-krb5/distinfo
new file mode 100644
index 000000000000..b2db1b41932d
--- /dev/null
+++ b/security/pecl-krb5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484941940
+SHA256 (krb5-1.1.1.tgz) = ba6474541ff5b6fdd4054969ead047645b669fff0e628ed6965214800c371024
+SIZE (krb5-1.1.1.tgz) = 36568
diff --git a/security/pecl-krb5/files/patch-krb5.c b/security/pecl-krb5/files/patch-krb5.c
new file mode 100644
index 000000000000..77cae46d3abb
--- /dev/null
+++ b/security/pecl-krb5/files/patch-krb5.c
@@ -0,0 +1,10 @@
+--- krb5.c.orig 2016-11-12 14:17:44 UTC
++++ krb5.c
+@@ -39,6 +39,7 @@
+
+ #include <sys/time.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+
+ #ifdef HAVE_KADM5
+ #include "kdb.h"
diff --git a/security/pecl-krb5/pkg-descr b/security/pecl-krb5/pkg-descr
new file mode 100644
index 000000000000..56f1e2f6dbe5
--- /dev/null
+++ b/security/pecl-krb5/pkg-descr
@@ -0,0 +1,7 @@
+An interface for maintaining credential caches (KRB5CCache),
+that can be used for authenticating against a kerberos5 realm.
+Bindings for nearly the complete GSSAPI (RFC2744).
+The administrative interface (KADM5).
+Support for HTTP Negotiate authentication via GSSAPI.
+
+WWW: https://pecl.php.net/package/krb5