aboutsummaryrefslogtreecommitdiff
path: root/security/pecl-scrypt
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-09-21 19:03:13 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-09-21 19:03:13 +0000
commiteb16b42a1bf8c491bcdbbe9cc2fc3c3e1ba9f49b (patch)
tree6dd10415fff6d65f25742490930f63c653081b45 /security/pecl-scrypt
parent114c007130f25f51905437e3d1c147d52b9d0f3d (diff)
downloadports-eb16b42a1bf8c491bcdbbe9cc2fc3c3e1ba9f49b.tar.gz
ports-eb16b42a1bf8c491bcdbbe9cc2fc3c3e1ba9f49b.zip
security/pecl-scrypt: various fixes and improvements
- Bump PORTREVISION - Replace STRIP_CMD with INSTALL_TARGET=install-strip - Remove STACKPROTECTOR and STACKPROTECTORALL from options - Add EXAMPLES and TEST to options PR: 200698 Submitted by: Horia Racoviceanu <horia@racoviceanu.com> (maintainer)
Notes
Notes: svn path=/head/; revision=397516
Diffstat (limited to 'security/pecl-scrypt')
-rw-r--r--security/pecl-scrypt/Makefile32
1 files changed, 21 insertions, 11 deletions
diff --git a/security/pecl-scrypt/Makefile b/security/pecl-scrypt/Makefile
index a2e8e4546e22..4200a602fb6d 100644
--- a/security/pecl-scrypt/Makefile
+++ b/security/pecl-scrypt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scrypt
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -17,33 +17,43 @@ USES= compiler tar:tgz
USE_PHP= hash
USE_PHPEXT= yes
USE_PHP_BUILD= yes
+INSTALL_TARGET= install-strip
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
PORTDOCS= README.md
-OPTIONS_DEFINE= DOCS
-OPTIONS_DEFAULT=STACKPROTECTOR
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+PORTEXAMPLES= scrypt.php
-OPTIONS_RADIO= BUFFER_OVERFLOW_PROTECTION
-OPTIONS_RADIO_BUFFER_OVERFLOW_PROTECTION= STACKPROTECTOR STACKPROTECTORALL
+TESTDIR= ${PREFIX}/tests/${PKGNAMEPREFIX}${PORTNAME}
+PORTTEST= run-tests.php tests/params.phpt tests/vectors.phpt
-STACKPROTECTOR_DESC= Protect functions with vulnerable objects
-STACKPROTECTORALL_DESC= Protect all functions
+OPTIONS_DEFINE= DOCS EXAMPLES TEST
-STACKPROTECTOR_CFLAGS= -fstack-protector
-STACKPROTECTORALL_CFLAGS= -fstack-protector-all
+TEST_PLIST_FILES= ${PORTTEST:S|^|${TESTDIR:S|${PREFIX}/||:S|$|/|}|}
.include <bsd.port.pre.mk>
+.if ${ARCH} == i386 && ${OSVERSION} < 1000036
+CFLAGS+= -fstack-protector
+.endif
+
.if ${ARCH} != amd64 && ${COMPILER_TYPE} == gcc
post-patch:
${REINPLACE_CMD} '/emmintrin.h/d' ${WRKSRC}/config.m4
.endif
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/${PORTNAME}.so
-
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
+
+.if ${PORT_OPTIONS:MTEST}
+ @${MKDIR} ${STAGEDIR}${TESTDIR}
+ ${INSTALL_DATA} ${PORTTEST:M*.php:S|^|${WRKSRC}/|} ${STAGEDIR}${TESTDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} tests ${STAGEDIR}${TESTDIR})
+.endif
+
.include <bsd.port.post.mk>