aboutsummaryrefslogtreecommitdiff
path: root/security/pecl-ssh2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-10-23 12:47:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-10-23 12:47:46 +0000
commitc068ed3cf3ff8597f7986a904562627cf98a688b (patch)
tree160169f92ab1fa56bbaff2b6dcd361885df6e3c2 /security/pecl-ssh2
parente11489c381b6172b81c7dbf483df287700919bac (diff)
downloadports-c068ed3cf3ff8597f7986a904562627cf98a688b.tar.gz
ports-c068ed3cf3ff8597f7986a904562627cf98a688b.zip
- Update to 0.11.2
PR: 161031 Submitted by: Kurt Jaeger <fbsd-ports@opsec.eu>
Notes
Notes: svn path=/head/; revision=284170
Diffstat (limited to 'security/pecl-ssh2')
-rw-r--r--security/pecl-ssh2/Makefile5
-rw-r--r--security/pecl-ssh2/distinfo4
-rw-r--r--security/pecl-ssh2/files/patch-ssh2.c50
3 files changed, 4 insertions, 55 deletions
diff --git a/security/pecl-ssh2/Makefile b/security/pecl-ssh2/Makefile
index 4f3c4b2ccdd6..df13386a5103 100644
--- a/security/pecl-ssh2/Makefile
+++ b/security/pecl-ssh2/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= ssh2
-PORTVERSION= 0.11
+PORTVERSION= 0.11.3
CATEGORIES= security pear
-MASTER_SITES= LOCAL/chinsan/PECL/
+MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= A PECL extension to the libssh2 library
diff --git a/security/pecl-ssh2/distinfo b/security/pecl-ssh2/distinfo
index c6e3c377c21d..0790d97a4669 100644
--- a/security/pecl-ssh2/distinfo
+++ b/security/pecl-ssh2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/ssh2-0.11.tgz) = 0125d1b4e32d667c36af8c5803ac21fd5f56e65bf9075eb77b4363540bd8359c
-SIZE (PECL/ssh2-0.11.tgz) = 24960
+SHA256 (ssh2-0.11.3.tgz) = b2518e101a53fd7940e49bb36a9b9559cbbfda946ebe5bb62e220d4ce132bf33
+SIZE (ssh2-0.11.3.tgz) = 23062
diff --git a/security/pecl-ssh2/files/patch-ssh2.c b/security/pecl-ssh2/files/patch-ssh2.c
deleted file mode 100644
index 23a9b468e0ca..000000000000
--- a/security/pecl-ssh2/files/patch-ssh2.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- ./ssh2.c.orig 2007-08-11 23:25:25.000000000 -0400
-+++ ./ssh2.c 2010-04-13 09:05:17.000000000 -0400
-@@ -48,7 +48,6 @@
- #endif
-
- #ifdef ZEND_ENGINE_2
--static
- ZEND_BEGIN_ARG_INFO(php_ssh2_first_arg_force_ref, 0)
- ZEND_ARG_PASS_INFO(1)
- ZEND_END_ARG_INFO()
-@@ -484,7 +483,7 @@
-
- ZEND_FETCH_RESOURCE(session, LIBSSH2_SESSION*, &zsession, -1, PHP_SSH2_SESSION_RES_NAME, le_ssh2_session);
-
--#if LIBSSH2_APINO < 200412301450
-+#if LIBSSH2_VERSION_NUM < 0x001000
- libssh2_session_methods(session, &kex, &hostkey, &crypt_cs, &crypt_sc, &mac_cs, &mac_sc, &comp_cs, &comp_sc, &lang_cs, &lang_sc);
- #else
- kex = libssh2_session_methods(session, LIBSSH2_METHOD_KEX);
-@@ -889,7 +888,7 @@
- for(i = 0; i < numfds; i++) {
- zval *subarray = *pollmap[i];
-
-- if (!subarray->is_ref && subarray->refcount > 1) {
-+ if (!Z_ISREF_P(subarray) && Z_REFCOUNT_P(subarray) > 1) {
- /* Make a new copy of the subarray zval* */
- MAKE_STD_ZVAL(subarray);
- *subarray = **pollmap[i];
-@@ -899,8 +898,8 @@
- zval_copy_ctor(subarray);
-
- /* Fixup its refcount */
-- subarray->is_ref = 0;
-- subarray->refcount = 1;
-+ Z_UNSET_ISREF_P(subarray);
-+ Z_SET_REFCOUNT_P(subarray, 1);
- }
- zend_hash_del(Z_ARRVAL_P(subarray), "revents", sizeof("revents"));
- add_assoc_long(subarray, "revents", pollfds[i].revents);
-@@ -1009,8 +1008,8 @@
- }
-
- zval_copy_ctor(&copyval);
-- copyval.is_ref = 0;
-- copyval.refcount = 1;
-+ Z_UNSET_ISREF(copyval);
-+ Z_SET_REFCOUNT(copyval, 1);
- convert_to_string(&copyval);
-
- if (*key == '*') {