aboutsummaryrefslogtreecommitdiff
path: root/security/pev
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2012-11-06 19:40:03 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2012-11-06 19:40:03 +0000
commit02595801c1f709afdb42ec6987a8d65a2ddf696b (patch)
treee0999282c37112f73073beaeb44da57c7360bc6d /security/pev
parent3488c13e3971f25131e5f5eea3b1dd2bf1ee1058 (diff)
downloadports-02595801c1f709afdb42ec6987a8d65a2ddf696b.tar.gz
ports-02595801c1f709afdb42ec6987a8d65a2ddf696b.zip
pev is a multiplatform PE analysis toolkit that
includes tools to retrieve and parsing information about Windows PE files. PR: ports/173390 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307087
Diffstat (limited to 'security/pev')
-rw-r--r--security/pev/Makefile23
-rw-r--r--security/pev/distinfo2
-rw-r--r--security/pev/files/patch-pev-0.60-a__Makefile11
-rw-r--r--security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile28
-rw-r--r--security/pev/files/patch-pev-0.60-a__src__Makefile30
-rw-r--r--security/pev/pkg-descr5
-rw-r--r--security/pev/pkg-plist14
7 files changed, 113 insertions, 0 deletions
diff --git a/security/pev/Makefile b/security/pev/Makefile
new file mode 100644
index 000000000000..b9d3461a40b2
--- /dev/null
+++ b/security/pev/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= pev
+PORTVERSION= 0.60
+CATEGORIES= security
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
+
+MAINTAINER= danilogondolfo@gmail.com
+COMMENT= The PE analysis toolkit
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+PATCH_STRIP= -p1
+
+MAN1= readpe.1 pedis.1 pepack.1 pescan.1 \
+ rva2ofs.1 pesec.1 ofs2rva.1 pestr.1 pehash.1
+
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/security/pev/distinfo b/security/pev/distinfo
new file mode 100644
index 000000000000..7248bb87d8ba
--- /dev/null
+++ b/security/pev/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pev-0.60.tar.gz) = 133d4698a25f3b40b95f203d30ddea5895b41db2c8cb7724433cc4ce165c2b43
+SIZE (pev-0.60.tar.gz) = 216584
diff --git a/security/pev/files/patch-pev-0.60-a__Makefile b/security/pev/files/patch-pev-0.60-a__Makefile
new file mode 100644
index 000000000000..fd6e4020be30
--- /dev/null
+++ b/security/pev/files/patch-pev-0.60-a__Makefile
@@ -0,0 +1,11 @@
+--- pev-0.60-b/Makefile 2012-11-01 20:32:45.016065672 -0200
++++ pev-0.60-a/Makefile 2012-11-01 20:32:59.815066896 -0200
+@@ -1,6 +1,6 @@
+ LIBPE_DIR = lib/libpe
+ PEV_DIR = src
+-MAKE = make
++MAKE = gmake
+ VERSION = 0.60
+ ZIPFILE = pev.zip
+
+diff -ur pev-0.60-b/lib/libpe/Makefile pev-0.60-a/lib/libpe/Makefile
diff --git a/security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile b/security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile
new file mode 100644
index 000000000000..d5c36d474f37
--- /dev/null
+++ b/security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile
@@ -0,0 +1,28 @@
+--- pev-0.60-b/lib/libpe/Makefile 2012-11-01 20:32:45.004068869 -0200
++++ pev-0.60-a/lib/libpe/Makefile 2012-11-01 20:37:48.321666630 -0200
+@@ -5,10 +5,10 @@
+
+ ####### Compiler, tools and options
+
+-PREFIX = /usr
++PREFIX = /usr/local
+ DEST = $(DESTDIR)/$(PREFIX)/lib
+ VERSION = 1.0
+-override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -c
++override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -shared -o libpe.so
+ ifneq ($(PLATFORM_OS), CYGWIN)
+ override CFLAGS += -fPIC
+ endif
+@@ -46,6 +46,11 @@
+ $(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
++else ifeq ($(PLATFORM_OS), FreeBSD)
++ $(STRIP) $(LIBNAME).so
++ $(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
++ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
++ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
+ else ifeq ($(PLATFORM_OS), Darwin)
+ $(STRIP) $(LIBNAME).dylib
+ $(INSTALL) $(LIBNAME).dylib $(DEST)/$(LIBNAME).$(VERSION).dylib
+diff -ur pev-0.60-b/src/Makefile pev-0.60-a/src/Makefile
diff --git a/security/pev/files/patch-pev-0.60-a__src__Makefile b/security/pev/files/patch-pev-0.60-a__src__Makefile
new file mode 100644
index 000000000000..7cf33c1c1700
--- /dev/null
+++ b/security/pev/files/patch-pev-0.60-a__src__Makefile
@@ -0,0 +1,30 @@
+--- pev-0.60-b/src/Makefile 2012-11-01 20:32:45.009065928 -0200
++++ pev-0.60-a/src/Makefile 2012-11-01 20:49:16.857787046 -0200
+@@ -5,12 +5,12 @@
+
+ ####### Compiler, tools and options
+
+-PREFIX = /usr
++PREFIX = /usr/local
+ DEST = $(DESTDIR)/$(PREFIX)/bin
+ LIBPE = ../lib/libpe
+ LIBUDIS86 = ../lib/libudis86
+-override LDFLAGS += -L$(LIBPE) -lpe
+-override CFLAGS += -I$(LIBPE) -W -Wall -Wextra -std=c99 -pedantic
++override LDFLAGS += -L/usr/local/lib -L$(LIBPE) -lpe
++override CFLAGS += -I/usr/local/include -I$(LIBPE) -W -Wall -Wextra -std=c99 -pedantic
+ ifeq ($(PLATFORM_OS), Darwin)
+ # We disable warnings for deprecated declarations since Apple deprecated OpenSSL in Mac OS X 10.7
+ override CFLAGS += -Wno-deprecated-declarations
+@@ -20,9 +20,9 @@
+ SOURCES = output.c
+ PROGS = readpe pedis pepack pescan rva2ofs pesec ofs2rva pestr pehash pestr
+ INSTALL = install -m 0755
+-SHAREDIR = /usr/share/pev
++SHAREDIR = /usr/local/share/pev
+ MAN = ../doc/manpages
+-MANDIR = /usr/share/man/man1
++MANDIR = /usr/local/man/man1
+
+ ####### Build rules
+
diff --git a/security/pev/pkg-descr b/security/pev/pkg-descr
new file mode 100644
index 000000000000..09736cf91866
--- /dev/null
+++ b/security/pev/pkg-descr
@@ -0,0 +1,5 @@
+pev is a multiplatform PE analysis toolkit that
+includes tools to retrieve and parsing information
+about Windows PE files.
+
+WWW: http://sourceforge.net/projects/pev/
diff --git a/security/pev/pkg-plist b/security/pev/pkg-plist
new file mode 100644
index 000000000000..72054e9af6e5
--- /dev/null
+++ b/security/pev/pkg-plist
@@ -0,0 +1,14 @@
+bin/readpe
+bin/pedis
+bin/pepack
+bin/pescan
+bin/rva2ofs
+bin/pesec
+bin/ofs2rva
+bin/pestr
+bin/pehash
+lib/libpe.so
+lib/libpe.so.1
+lib/libpe.so.1.0
+%%DATADIR%%/userdb.txt
+@dirrm share/pev