aboutsummaryrefslogtreecommitdiff
path: root/security/pev
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-09-24 16:28:25 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-09-24 16:28:25 +0000
commit276b046cb05c648a28f696b4f404faba48b4c28c (patch)
treefdbfbf4c9ec4fb87fcf805c10fa230dd01cf3bf1 /security/pev
parent6c91c88db09cfdd5a497dce5212c996e8cf31474 (diff)
downloadports-276b046cb05c648a28f696b4f404faba48b4c28c.tar.gz
ports-276b046cb05c648a28f696b4f404faba48b4c28c.zip
- Use new LIB_DEPENDS syntax
- Use USES=gmake instead of USE_GMAKE - Recreate distinfo (package modified without changing version) - Recreate patches with makepatch - Fix build on CURRENT - Enable staging support Approved by: wg (mentor)
Notes
Notes: svn path=/head/; revision=328158
Diffstat (limited to 'security/pev')
-rw-r--r--security/pev/Makefile14
-rw-r--r--security/pev/distinfo4
-rw-r--r--security/pev/files/patch-lib__libpe__Makefile34
-rw-r--r--security/pev/files/patch-pev-0.60-a__Makefile11
-rw-r--r--security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile28
-rw-r--r--security/pev/files/patch-src__Makefile (renamed from security/pev/files/patch-pev-0.60-a__src__Makefile)31
-rw-r--r--security/pev/pkg-plist19
7 files changed, 71 insertions, 70 deletions
diff --git a/security/pev/Makefile b/security/pev/Makefile
index 0f323d2a0cdd..8941e973dea9 100644
--- a/security/pev/Makefile
+++ b/security/pev/Makefile
@@ -2,24 +2,18 @@
PORTNAME= pev
PORTVERSION= 0.60
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
MAINTAINER= danilogondolfo@gmail.com
COMMENT= The PE analysis toolkit
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
-PATCH_STRIP= -p1
+MAKE_ARGS+= PREFIX=${STAGEDIR}/${PREFIX} MAKE=${GMAKE}
-MAN1= readpe.1 pedis.1 pepack.1 pescan.1 \
- rva2ofs.1 pesec.1 ofs2rva.1 pestr.1 pehash.1
-
-MANCOMPRESSED= yes
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/pev/distinfo b/security/pev/distinfo
index 7248bb87d8ba..2596a6d50fad 100644
--- a/security/pev/distinfo
+++ b/security/pev/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pev-0.60.tar.gz) = 133d4698a25f3b40b95f203d30ddea5895b41db2c8cb7724433cc4ce165c2b43
-SIZE (pev-0.60.tar.gz) = 216584
+SHA256 (pev-0.60.tar.gz) = 9f7f6c45644a66a90ec35ebd40ec8aedc2a8b80d7fbe2771a7061c1691639099
+SIZE (pev-0.60.tar.gz) = 212932
diff --git a/security/pev/files/patch-lib__libpe__Makefile b/security/pev/files/patch-lib__libpe__Makefile
new file mode 100644
index 000000000000..5fe0d7aa2c11
--- /dev/null
+++ b/security/pev/files/patch-lib__libpe__Makefile
@@ -0,0 +1,34 @@
+--- ./lib/libpe/Makefile.orig 2012-10-31 01:59:14.000000000 -0200
++++ ./lib/libpe/Makefile 2013-09-24 12:03:36.000000000 -0300
+@@ -5,16 +5,15 @@
+
+ ####### Compiler, tools and options
+
+-PREFIX = /usr
+-DEST = $(DESTDIR)/$(PREFIX)/lib
++DEST = $(PREFIX)/lib
+ VERSION = 1.0
+-override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -c
++override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -shared -o libpe.so
+ ifneq ($(PLATFORM_OS), CYGWIN)
+ override CFLAGS += -fPIC
+ endif
+ SRC = pe.c
+ RM = rm -f
+-CC = gcc
++CC ?= ${CC}
+ SYMLINK = ln -sf
+ ifeq ($(PLATFORM_OS), Darwin)
+ STRIP = strip -x
+@@ -46,6 +45,11 @@
+ $(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
++else ifeq ($(PLATFORM_OS), FreeBSD)
++ $(STRIP) $(LIBNAME).so
++ $(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
++ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
++ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
+ else ifeq ($(PLATFORM_OS), Darwin)
+ $(STRIP) $(LIBNAME).dylib
+ $(INSTALL) $(LIBNAME).dylib $(DEST)/$(LIBNAME).$(VERSION).dylib
diff --git a/security/pev/files/patch-pev-0.60-a__Makefile b/security/pev/files/patch-pev-0.60-a__Makefile
deleted file mode 100644
index fd6e4020be30..000000000000
--- a/security/pev/files/patch-pev-0.60-a__Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- pev-0.60-b/Makefile 2012-11-01 20:32:45.016065672 -0200
-+++ pev-0.60-a/Makefile 2012-11-01 20:32:59.815066896 -0200
-@@ -1,6 +1,6 @@
- LIBPE_DIR = lib/libpe
- PEV_DIR = src
--MAKE = make
-+MAKE = gmake
- VERSION = 0.60
- ZIPFILE = pev.zip
-
-diff -ur pev-0.60-b/lib/libpe/Makefile pev-0.60-a/lib/libpe/Makefile
diff --git a/security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile b/security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile
deleted file mode 100644
index d5c36d474f37..000000000000
--- a/security/pev/files/patch-pev-0.60-a__lib__libpe__Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
---- pev-0.60-b/lib/libpe/Makefile 2012-11-01 20:32:45.004068869 -0200
-+++ pev-0.60-a/lib/libpe/Makefile 2012-11-01 20:37:48.321666630 -0200
-@@ -5,10 +5,10 @@
-
- ####### Compiler, tools and options
-
--PREFIX = /usr
-+PREFIX = /usr/local
- DEST = $(DESTDIR)/$(PREFIX)/lib
- VERSION = 1.0
--override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -c
-+override CFLAGS += -W -Wall -Wextra -pedantic -std=c99 -shared -o libpe.so
- ifneq ($(PLATFORM_OS), CYGWIN)
- override CFLAGS += -fPIC
- endif
-@@ -46,6 +46,11 @@
- $(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
- cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
- cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
-+else ifeq ($(PLATFORM_OS), FreeBSD)
-+ $(STRIP) $(LIBNAME).so
-+ $(INSTALL) $(LIBNAME).so $(DEST)/$(LIBNAME).so.$(VERSION)
-+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so
-+ cd $(DEST); $(SYMLINK) $(LIBNAME).so.$(VERSION) $(LIBNAME).so.1
- else ifeq ($(PLATFORM_OS), Darwin)
- $(STRIP) $(LIBNAME).dylib
- $(INSTALL) $(LIBNAME).dylib $(DEST)/$(LIBNAME).$(VERSION).dylib
-diff -ur pev-0.60-b/src/Makefile pev-0.60-a/src/Makefile
diff --git a/security/pev/files/patch-pev-0.60-a__src__Makefile b/security/pev/files/patch-src__Makefile
index 7cf33c1c1700..03b3d0179de9 100644
--- a/security/pev/files/patch-pev-0.60-a__src__Makefile
+++ b/security/pev/files/patch-src__Makefile
@@ -1,12 +1,12 @@
---- pev-0.60-b/src/Makefile 2012-11-01 20:32:45.009065928 -0200
-+++ pev-0.60-a/src/Makefile 2012-11-01 20:49:16.857787046 -0200
-@@ -5,12 +5,12 @@
-
+--- ./src/Makefile.orig 2013-01-23 10:37:31.000000000 -0200
++++ ./src/Makefile 2013-09-24 12:03:20.000000000 -0300
+@@ -5,24 +5,23 @@
+
####### Compiler, tools and options
-
+
-PREFIX = /usr
-+PREFIX = /usr/local
- DEST = $(DESTDIR)/$(PREFIX)/bin
+-DEST = $(DESTDIR)/$(PREFIX)/bin
++DEST = $(PREFIX)/bin
LIBPE = ../lib/libpe
LIBUDIS86 = ../lib/libudis86
-override LDFLAGS += -L$(LIBPE) -lpe
@@ -14,17 +14,20 @@
+override LDFLAGS += -L/usr/local/lib -L$(LIBPE) -lpe
+override CFLAGS += -I/usr/local/include -I$(LIBPE) -W -Wall -Wextra -std=c99 -pedantic
ifeq ($(PLATFORM_OS), Darwin)
- # We disable warnings for deprecated declarations since Apple deprecated OpenSSL in Mac OS X 10.7
- override CFLAGS += -Wno-deprecated-declarations
-@@ -20,9 +20,9 @@
+ # We disable warnings for deprecated declarations since Apple deprecated OpenSSL in Mac OS X 10.7
+ override CFLAGS += -Wno-deprecated-declarations
+ endif
+-CC = gcc
++CC ?= ${CC}
+ RM = rm -f
SOURCES = output.c
PROGS = readpe pedis pepack pescan rva2ofs pesec ofs2rva pestr pehash pestr
INSTALL = install -m 0755
-SHAREDIR = /usr/share/pev
-+SHAREDIR = /usr/local/share/pev
++SHAREDIR = ${PREFIX}/share/pev
MAN = ../doc/manpages
-MANDIR = /usr/share/man/man1
-+MANDIR = /usr/local/man/man1
-
++MANDIR = ${PREFIX}/man/man1
+
####### Build rules
-
+
diff --git a/security/pev/pkg-plist b/security/pev/pkg-plist
index 72054e9af6e5..d10d540a97d2 100644
--- a/security/pev/pkg-plist
+++ b/security/pev/pkg-plist
@@ -1,14 +1,23 @@
-bin/readpe
+bin/ofs2rva
bin/pedis
+bin/pehash
bin/pepack
bin/pescan
-bin/rva2ofs
bin/pesec
-bin/ofs2rva
bin/pestr
-bin/pehash
+bin/readpe
+bin/rva2ofs
lib/libpe.so
lib/libpe.so.1
lib/libpe.so.1.0
+man/man1/ofs2rva.1.gz
+man/man1/pedis.1.gz
+man/man1/pehash.1.gz
+man/man1/pepack.1.gz
+man/man1/pescan.1.gz
+man/man1/pesec.1.gz
+man/man1/pestr.1.gz
+man/man1/readpe.1.gz
+man/man1/rva2ofs.1.gz
%%DATADIR%%/userdb.txt
-@dirrm share/pev
+@dirrmtry %%DATADIR%%