aboutsummaryrefslogtreecommitdiff
path: root/security/pf
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-06-16 03:14:27 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-06-16 03:14:27 +0000
commit9c34cb3269967396bd85220d7ba536a88f804fb5 (patch)
treeb971bdfe1f78322f2e9de7b482f5a2d1879eb70c /security/pf
parentbc7de3495f489a63887020ea707aa776e3d4a632 (diff)
downloadports-9c34cb3269967396bd85220d7ba536a88f804fb5.tar.gz
ports-9c34cb3269967396bd85220d7ba536a88f804fb5.zip
Notes
Diffstat (limited to 'security/pf')
-rw-r--r--security/pf/Makefile2
-rw-r--r--security/pf/files/patch-aa32
2 files changed, 33 insertions, 1 deletions
diff --git a/security/pf/Makefile b/security/pf/Makefile
index 56825251bdde..264337e12747 100644
--- a/security/pf/Makefile
+++ b/security/pf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pf_freebsd
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://pf4freebsd.love2party.net/
.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
diff --git a/security/pf/files/patch-aa b/security/pf/files/patch-aa
new file mode 100644
index 000000000000..24724598f4fb
--- /dev/null
+++ b/security/pf/files/patch-aa
@@ -0,0 +1,32 @@
+--- freebsd_tcpdump/print-pflog.c.orig Fri Jun 13 18:14:50 2003
++++ freebsd_tcpdump/print-pflog.c Fri Jun 13 18:15:39 2003
+@@ -64,7 +64,9 @@
+ u_int length = h->len;
+ u_int caplen = h->caplen;
+ const struct ip *ip;
++#ifdef INET6
+ const struct ip6_hdr *ip6;
++#endif
+ const struct pfloghdr *hdr;
+ u_short res;
+ char reason[128], *why;
+@@ -129,13 +131,16 @@
+ if (xflag)
+ default_print((const u_char *)ip,
+ caplen - PFLOG_HDRLEN);
+- } else {
++ }
++#ifdef INET6
++ else {
+ ip6 = (struct ip6_hdr *)(p + PFLOG_HDRLEN);
+ ip6_print((const u_char *)ip6, length);
+ if (xflag)
+ default_print((const u_char *)ip6,
+ caplen - PFLOG_HDRLEN);
+ }
++#endif
+
+ out:
+ putchar('\n');
+
+