aboutsummaryrefslogtreecommitdiff
path: root/security/pgpin
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-03-31 11:36:43 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-03-31 11:36:43 +0000
commitcb9a0ddd3822d76704524dda0b1742e7a7377377 (patch)
treef47ef28c0a7c7747d72e0e59f6495ffebbcd0778 /security/pgpin
parent1aafd2fd714fe6d70668fb86354decc45015a1e3 (diff)
downloadports-cb9a0ddd3822d76704524dda0b1742e7a7377377.tar.gz
ports-cb9a0ddd3822d76704524dda0b1742e7a7377377.zip
PGP (Pretty Good Privacy) is a public key encryption pack-
age to protect E-mail and data files. It lets you commu- nicate securely with people you've never met, with no secure channels needed for prior exchange of keys. It's well featured and fast, with sophisticated key management, digital signatures, data compression, and good ergonomic design. Contributors: Matthias Bruestle for the myetsid feature. Lutz Donnerhacke for the pgp2.6.3in development. Ingmar Camphausen, Thomas Roessler, a.o. for extensive testing. WWW: http://www.in-ca.individual.net/ FTP: ftp://ftp.fu-berlin.de/doc/IN/IN-CA/pgp/pgp263in/files/pgp263in.changes
Notes
Notes: svn path=/head/; revision=40651
Diffstat (limited to 'security/pgpin')
-rw-r--r--security/pgpin/Makefile49
-rw-r--r--security/pgpin/distinfo1
-rw-r--r--security/pgpin/files/CHANGES94
-rw-r--r--security/pgpin/files/patch-fileio.h11
-rw-r--r--security/pgpin/files/patch-makefile28
-rw-r--r--security/pgpin/pkg-comment1
-rw-r--r--security/pgpin/pkg-descr15
-rw-r--r--security/pgpin/pkg-plist12
8 files changed, 211 insertions, 0 deletions
diff --git a/security/pgpin/Makefile b/security/pgpin/Makefile
new file mode 100644
index 000000000000..22f4016aecaf
--- /dev/null
+++ b/security/pgpin/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: pgpin
+# Date created: 23 Mar 2001
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgpin
+PORTVERSION= 010322
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.fu-berlin.de/doc/IN/IN-CA/pgp/pgp263in/
+DISTNAME= pgp263in010322
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+WRKSRC= ${WRKDIR}/pgp263in/src
+
+MAKEFILE= makefile
+ALL_TARGET= freebsd-${MACHINE_ARCH} OS_CFLAGS="${CFLAGS}"
+PGPLIB= ${PREFIX}/lib/pgpin
+MAN1= pgpin.1
+
+do-install:
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} -c -o bin -g bin -m 555 \
+ pgp ${PREFIX}/bin/pgpin
+ cd ${WRKSRC}/../doc; \
+ ${INSTALL_MAN} -c -o bin -g bin -m 444 \
+ pgp.1 ${PREFIX}/man/man1/pgpin.1
+ -${MKDIR} ${PGPLIB}
+ ${CHMOD} 555 ${PGPLIB}
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 \
+ ${FILESDIR}/CHANGES ${PGPLIB}
+ cd ${WRKSRC}/..; \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 \
+ pgp.hlp doc/pgpdoc1.txt doc/pgpdoc2.txt ${PGPLIB}; \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 \
+ language.txt ${PGPLIB}/language.txt-dist; \
+ [ -f ${PGPLIB}/language.txt ] || \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 \
+ language.txt ${PGPLIB}; \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 \
+ config.txt ${PGPLIB}/config.txt-dist; \
+ [ -f ${PGPLIB}/config.txt ] || \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 \
+ config.txt ${PGPLIB}
+ -${PREFIX}/bin/pgpin > /dev/null 2>&1 # update .idx file
+
+.include <bsd.port.mk>
diff --git a/security/pgpin/distinfo b/security/pgpin/distinfo
new file mode 100644
index 000000000000..d2430377c7f4
--- /dev/null
+++ b/security/pgpin/distinfo
@@ -0,0 +1 @@
+MD5 (pgp263in010322.tgz) = 4e2a471e12d6735f63cf2e9c661a3bea
diff --git a/security/pgpin/files/CHANGES b/security/pgpin/files/CHANGES
new file mode 100644
index 000000000000..db78bb936a47
--- /dev/null
+++ b/security/pgpin/files/CHANGES
@@ -0,0 +1,94 @@
+20010322:
+ - Protect against the Czech attack of modified secret key files. (Cool!)
+ - Protect against MPI computing errors. (more programm errors than Bellcore)
+
+20001006:
+ - Alter the ARJ signature to the current version.
+ - Prevent automatic renaming of command line arguments
+ used for file names (+batchmode).
+
+199990902:
+ - Up to 32bit KeyID can be selected.
+ - Allow batchmode to revoke certificates (and keys :-{).
+
+199971007:
+ - Bugfix of the previous bugfix. I'm an idiot unable to program in C.
+ - language.txt (German part) brushed up.
+
+199971006:
+ - Bugfix of ordinary PGP: -kc failed to deal correctly w/ DSS signatures.
+
+199970905:
+ - Bugfix: Compile under MSDOS and OSF.
+ - Corrected some spelling errors.
+ - ESC is plain text, too.
+ - Somewhat more verbose output.
+ - 8192 bit RSA support
+
+199970828:
+ - Certificates of unknown pubkeys are suppressed.
+ (New Option UNKNOWN_CERTS (On/Off))
+ - pgp -kvv shows the quality of user identification.
+
+199970729:
+ - Bugfix: Validity period is read correctly from the key ring.
+
+199970529:
+ - Certificates from revoked keys are invalid.
+
+199970513:
+ - Certificates from unknown users are handled correctly.
+
+199970512:
+ - Certificate revocations are correctly handled and displayed.
+
+199970418:
+ - support of a separate "encrypt to self" id
+ - certificates signed with compromised keys are invalid now
+ - support of certificate revocation certificates:
+ You can revoke your ID without loosing your key.
+
+199970404:
+ - try the corresponding key, if the key of the wrong purpose is used,
+ so 'pgp -se file myname -u myname' will automatically choose the right
+ keys.
+ - SIGN keys can be used to decrypt, but PGP will warn the user.
+ - The language modul could not distinguish two strings, so changed them.
+ - Recommendations for key generating changed: Larger keys, userid options.
+
+199970403:
+ - 2.6.3ia patch included
+ - bugfixes
+
+199970402:
+ - While certifying a key the certifier can specify how (s)he checked
+ the user's real identity. (This question is quite different to
+ the question whether the key was presented by this person or not!)
+ - SIGN keys cannot encrypt.
+ - SIGN keys cannot decrypt (so you can't read it!)
+ - ENCR keys cannot sign or certify.
+ - Signatures or certificates by ENCR keys are invalid. (even self signed)
+ - Signatures or certificates are invalid, if their timestamp is not covered
+ by the validity period of the public key. (too young or too old)
+ - Expired keys are kept but marked. (same for keys valid in future)
+ - Purpose and expire of a key are set while generating the key.
+ It is derived from the userid as described in the policy of the IN-CH.
+
+References:
+ http://www.in-ca.individual.net/
+ ftp://ftp.iks-jena.de/pub/mitarb/lutz/crypt/software/pgp/
+ Diffs and full source (tgz)
+ *.asc are detached signatures.
+
+Contributors:
+ Matthias Bruestle for the myetsid feature.
+ Lutz Donnerhacke for the pgp2.6.3in development.
+ Ingmar Camphausen, Thomas Roessler, a.o. for extensive testing.
+
+Todo:
+ - New trust models for revoked certificates.
+ - Time stamping features (using the Eternity Logfile:
+ http://www.iks-jena.de/mitarb/lutz/logfile/)
+ - Support of EBP and PGP5.0 features.
+ - Better internal key management for faster access.
+ - Direct support for keyserver issues.
diff --git a/security/pgpin/files/patch-fileio.h b/security/pgpin/files/patch-fileio.h
new file mode 100644
index 000000000000..a745a57ae0b8
--- /dev/null
+++ b/security/pgpin/files/patch-fileio.h
@@ -0,0 +1,11 @@
+--- fileio.h.orig Mon Jan 12 09:13:04 1998
++++ fileio.h Fri Mar 23 13:55:39 2001
+@@ -28,7 +28,7 @@
+ #ifdef LINUX
+ # define PGP_SYSTEM_DIR "/usr/lib/pgp/"
+ #else
+-# define PGP_SYSTEM_DIR "/usr/local/lib/pgp/"
++# define PGP_SYSTEM_DIR "/usr/local/lib/pgpin/"
+ #endif
+ #define FOPRBIN "r"
+ #define FOPRTXT "r"
diff --git a/security/pgpin/files/patch-makefile b/security/pgpin/files/patch-makefile
new file mode 100644
index 000000000000..44b3734895a7
--- /dev/null
+++ b/security/pgpin/files/patch-makefile
@@ -0,0 +1,28 @@
+--- makefile.orig Mon Jan 12 09:15:06 1998
++++ makefile Fri Mar 23 13:41:03 2001
+@@ -79,7 +79,7 @@
+ @echo "where <system> can be:"
+ @echo " 386bsd, 3b1, 3b1_asm, aix370, aix386, amix-68k-gcc, apollo,"
+ @echo " apollo-gcc, atari,aux(*), aux-gcc, bsd, bsdgcc, convexos,"
+- @echo " dgux, djgpp, encore, freebsd, hpux-68k(*), hpux-68k-ansi,"
++ @echo " dgux, djgpp, encore, freebsd-{alpha,i386}, hpux-68k(*), hpux-68k-ansi,"
+ @echo " hpux-68k-gcc, hpux-pa(*), hpux-pa-ansi, hpux-pa-gcc, hpux9-pa-ansi,"
+ @echo " irix, irix_asm, isc, isc_asm, linux, linux-aout, linux-68k,"
+ @echo " machten, mach_386, mips-ultrix, netbsd, netbsd_68k, newsasm,"
+@@ -175,9 +175,14 @@
+ $(MAKE) all CC=gcc LD=gcc \
+ CFLAGS="$(RSAINCDIR) -O2 -DHIGHFIRST -DUNIX -DPORTABLE -DIDEA32"
+
+-freebsd:
++freebsd-i386:
+ $(MAKE) all LD="$(CC) -s" OBJS_EXT="_80386.o _zmatch.o" \
+- CFLAGS="$(RSAINCDIR) -O2 -fno-strength-reduce -DUNIX -DIDEA32 -DASM \
++ CFLAGS="$(RSAINCDIR) $(OS_CFLAGS) -DUNIX -DIDEA32 -DASM \
++ -DMAX_NAMELEN=255"
++
++freebsd-alpha:
++ $(MAKE) all LD="$(CC) -s" \
++ CFLAGS="$(RSAINCDIR) $(OS_CFLAGS) -DPORTABLE -DUNIX -DIDEA32 \
+ -DMAX_NAMELEN=255"
+
+ 386bsd:
diff --git a/security/pgpin/pkg-comment b/security/pgpin/pkg-comment
new file mode 100644
index 000000000000..a4ebf6c23f19
--- /dev/null
+++ b/security/pgpin/pkg-comment
@@ -0,0 +1 @@
+PGP International version - improved for use in IN-CA
diff --git a/security/pgpin/pkg-descr b/security/pgpin/pkg-descr
new file mode 100644
index 000000000000..de21590fb4f9
--- /dev/null
+++ b/security/pgpin/pkg-descr
@@ -0,0 +1,15 @@
+PGP (Pretty Good Privacy) is a public key encryption pack-
+age to protect E-mail and data files. It lets you commu-
+nicate securely with people you've never met, with no
+secure channels needed for prior exchange of keys. It's
+well featured and fast, with sophisticated key management,
+digital signatures, data compression, and good ergonomic
+design.
+
+Contributors:
+ Matthias Bruestle for the myetsid feature.
+ Lutz Donnerhacke for the pgp2.6.3in development.
+ Ingmar Camphausen, Thomas Roessler, a.o. for extensive testing.
+
+WWW: http://www.in-ca.individual.net/
+FTP: ftp://ftp.fu-berlin.de/doc/IN/IN-CA/pgp/pgp263in/files/pgp263in.changes
diff --git a/security/pgpin/pkg-plist b/security/pgpin/pkg-plist
new file mode 100644
index 000000000000..727f6a60b8c1
--- /dev/null
+++ b/security/pgpin/pkg-plist
@@ -0,0 +1,12 @@
+bin/pgpin
+lib/pgpin/CHANGES
+lib/pgpin/pgp.hlp
+lib/pgpin/pgpdoc1.txt
+lib/pgpin/pgpdoc2.txt
+@unexec if cmp -s %D/lib/pgpin/language.txt %D/lib/pgpin/language.txt-dist; then rm -f %D/lib/pgpin/language.txt; fi
+lib/pgpin/language.txt-dist
+@exec [ ! -f %B/language.txt ] && cp %B/%f %B/language.txt
+@unexec if cmp -s %D/lib/pgpin/config.txt %D/lib/pgpin/config.txt-dist; then rm -f %D/lib/pgpin/config.txt; fi
+lib/pgpin/config.txt-dist
+@exec [ ! -f %B/config.txt ] && cp %B/%f %B/config.txt
+@dirrm lib/pgpin