aboutsummaryrefslogtreecommitdiff
path: root/security/pinentry
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 18:02:10 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 18:02:10 +0000
commit4729f7306b2168dd1f5699bad38ae91bab102474 (patch)
tree03b6ae7da40af6bd957d75c566c89d18c30d7fdd /security/pinentry
parent9cc6398f8dd21d6af95b65f52656bfeeaaaf31ce (diff)
downloadports-4729f7306b2168dd1f5699bad38ae91bab102474.tar.gz
ports-4729f7306b2168dd1f5699bad38ae91bab102474.zip
security/pinentry: remove QT4 option (Qt4 deprecation)
- this breaks security/pinentry-qt4 until removal Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=495937
Diffstat (limited to 'security/pinentry')
-rw-r--r--security/pinentry/Makefile21
1 files changed, 3 insertions, 18 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index e0d0296f4e83..73f953add6f1 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pinentry
PORTVERSION= 1.1.0
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= security
MASTER_SITES= GNUPG/pinentry
@@ -22,7 +22,7 @@ NO_BUILD= yes
PLIST_FILES= bin/pinentry
OPTIONS_SINGLE= FRONTEND
-OPTIONS_SINGLE_FRONTEND= TTY NCURSES FLTK GTK2 QT4 QT5 GNOME3
+OPTIONS_SINGLE_FRONTEND= TTY NCURSES FLTK GTK2 QT5 GNOME3
OPTIONS_DEFAULT= TTY
FRONTEND_DESC= Default frontend
@@ -43,10 +43,6 @@ GTK2_DESC= Gtk+ 2 frontend
PINENTRY_GTK2= pinentry-gtk-2
GTK2_RUN_DEPENDS= ${PINENTRY_GTK2}:security/pinentry-gtk2
-QT4_DESC= Qt 4 frontend
-PINENTRY_QT4= pinentry-qt4
-QT4_RUN_DEPENDS= ${PINENTRY_QT4}:security/pinentry-qt4
-
QT5_DESC= Qt 5 frontend
PINENTRY_QT5= pinentry-qt5
QT5_RUN_DEPENDS= ${PINENTRY_QT5}:security/pinentry-qt5
@@ -63,11 +59,6 @@ PINENTRY_BIN= ${PINENTRY_${gui}}
. endif
.endfor
-.if ${PORT_OPTIONS:MQT4}
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-.endif
-
do-install:
${LN} -sf ${PINENTRY_BIN} ${STAGEDIR}${PREFIX}/bin/pinentry
${INSTALL_DATA} ${WRKSRC}/doc/pinentry.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
@@ -98,13 +89,7 @@ PLIST_FILES= bin/pinentry-gnome3
CONFIGURE_ARGS+=--disable-pinentry-gnome3
.endif
-.if ${PINENTRY_GUI} == "qt4"
-USES+= compiler:c++11-lib qt:4
-USE_QT= corelib gui moc_build
-PLIST_FILES= bin/pinentry-qt4
-CONFIGURE_ARGS+=--disable-pinentry-qt5 \
- --program-suffix=4
-.elif ${PINENTRY_GUI} == "qt5"
+.if ${PINENTRY_GUI} == "qt5"
USES+= compiler:c++11-lib qt:5
USE_QT= core gui widgets buildtools_build
PLIST_FILES= bin/pinentry-qt5