aboutsummaryrefslogtreecommitdiff
path: root/security/pinentry
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-21 07:29:54 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-21 07:29:54 +0000
commit867e00365a49608e3f8c3c56a39ad838f40aac2d (patch)
tree979a4221261011c6ccfcc9511ecb9aa4ccad09f0 /security/pinentry
parentb4810c37fb4f83d3e70381f60a1dd322485e4aad (diff)
downloadports-867e00365a49608e3f8c3c56a39ad838f40aac2d.tar.gz
ports-867e00365a49608e3f8c3c56a39ad838f40aac2d.zip
security/pinetry-qt4: set to use c+++11 standard (fixes gcc5)
Unfortunately this still doesn't build on FreeBSD 10 which uses libc++. It is unknown if it builds on FreeBSD11, but it has been ignored on FreeBSD11. The main benefit is for gcc5 support right now. I confirmed that it still builds on FreeBSD 8 and FreeBSD 9. Approved by: blanket (gcc5)
Notes
Notes: svn path=/head/; revision=384409
Diffstat (limited to 'security/pinentry')
-rw-r--r--security/pinentry/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 98bf0cd7587c..383d0075de97 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -68,6 +68,8 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.if ${PINENTRY_GUI} == "qt4"
+USES+= compiler:c++11-lib
+USE_CXXSTD= c++11
. if exists(/usr/lib/libc++.so)
IGNORE= does not compile with libc++
. endif