aboutsummaryrefslogtreecommitdiff
path: root/security/pixiewps
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-12-02 17:23:32 +0000
committerMark Felder <feld@FreeBSD.org>2015-12-02 17:23:32 +0000
commitbd01b7325f84f1d0e938910f31253ee12ebf1d94 (patch)
treefff2e286097747bdf23c958052788ad1fc6b8089 /security/pixiewps
parent7010cfb0677d79cb91061bec055e3ffc73317671 (diff)
downloadports-bd01b7325f84f1d0e938910f31253ee12ebf1d94.tar.gz
ports-bd01b7325f84f1d0e938910f31253ee12ebf1d94.zip
Pixiewps is a tool written in C used to bruteforce offline the WPS pin
exploiting the low or non-existing entropy of some APs (pixie dust attack). It is meant for educational purposes only. All credits for the research go to Dominique Bongard. WWW: https://github.com/wiire/pixiewps PR: 204030 Submitted by: Franz Bettag <franz@bett.ag>
Notes
Notes: svn path=/head/; revision=402839
Diffstat (limited to 'security/pixiewps')
-rw-r--r--security/pixiewps/Makefile28
-rw-r--r--security/pixiewps/distinfo2
-rw-r--r--security/pixiewps/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/security/pixiewps/Makefile b/security/pixiewps/Makefile
new file mode 100644
index 000000000000..bf099bab669f
--- /dev/null
+++ b/security/pixiewps/Makefile
@@ -0,0 +1,28 @@
+# Created by: Franz Bettag <franz@bett.ag>
+# $FreeBSD$
+
+PORTNAME= pixiewps
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= https://github.com/wiire/pixiewps/
+
+MAINTAINER= franz@bett.ag
+COMMENT= Offline WPS bruteforce utility
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= wiire
+GH_TAGNAME= 08a78c3c
+
+USE_OPENSSL= yes
+
+USES= gmake
+WRKSRC_SUBDIR= src/
+
+PLIST_FILES= bin/pixiewps
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/pixiewps/distinfo b/security/pixiewps/distinfo
new file mode 100644
index 000000000000..6f1592d6b03e
--- /dev/null
+++ b/security/pixiewps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wiire-pixiewps-1.1-08a78c3c_GH0.tar.gz) = 16b65e4fc376b3812135f83b450c9e286ef12c872ac91b048710e3e442d44e75
+SIZE (wiire-pixiewps-1.1-08a78c3c_GH0.tar.gz) = 28836
diff --git a/security/pixiewps/pkg-descr b/security/pixiewps/pkg-descr
new file mode 100644
index 000000000000..e230a226759b
--- /dev/null
+++ b/security/pixiewps/pkg-descr
@@ -0,0 +1,6 @@
+Pixiewps is a tool written in C used to bruteforce offline the WPS pin
+exploiting the low or non-existing entropy of some APs (pixie dust attack).
+It is meant for educational purposes only.
+All credits for the research go to Dominique Bongard.
+
+WWW: https://github.com/wiire/pixiewps