aboutsummaryrefslogtreecommitdiff
path: root/security/pkcs11-gateway
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2011-04-06 09:42:40 +0000
committerAlex Dupre <ale@FreeBSD.org>2011-04-06 09:42:40 +0000
commitd8e2db78aa9fcb0ea01d6d0271162dcadbc6e412 (patch)
tree8e772b3cdc59a8db4c993b9a2f501f781be91a79 /security/pkcs11-gateway
parentd29ca23058c1abb597c8b51dc7e721f7d8d235cc (diff)
downloadports-d8e2db78aa9fcb0ea01d6d0271162dcadbc6e412.tar.gz
ports-d8e2db78aa9fcb0ea01d6d0271162dcadbc6e412.zip
pkcs11-gateway is a software that allows you to use a Linux 32-bit PKCS#11
module on FreeBSD i386/amd64. It consists of a FreeBSD Cryptoki wrapper library that serializes and forwards PKCS#11 function calls to a Linux server program that dlopen() and use the real module. The communication between the two components is via a UNIX socket. pkcs11-gateway is based on the rpc-layer of Gnome Keyring. - Alex Dupre ale@FreeBSD.org
Notes
Notes: svn path=/head/; revision=272299
Diffstat (limited to 'security/pkcs11-gateway')
-rw-r--r--security/pkcs11-gateway/Makefile38
-rw-r--r--security/pkcs11-gateway/distinfo2
-rw-r--r--security/pkcs11-gateway/pkg-descr9
3 files changed, 49 insertions, 0 deletions
diff --git a/security/pkcs11-gateway/Makefile b/security/pkcs11-gateway/Makefile
new file mode 100644
index 000000000000..2fed029fc04f
--- /dev/null
+++ b/security/pkcs11-gateway/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: pkcs11-gateway
+# Date created: 1 Apr 2011
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkcs11-gateway
+PORTVERSION= 1.0
+CATEGORIES= security devel linux
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= ale
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A wrapper Cryptoki library to use Linux PKCS\#11 modules
+
+LICENSE= LGPL20
+
+MAKEFILE= Makefile.FreeBSD
+USE_LDCONFIG= yes
+USE_LINUX= yes
+
+PLIST_FILES= bin/pkcs11-gateway lib/libpkcs11-gateway.so \
+ lib/libpkcs11-gateway.so.1
+
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pkcs11-gateway ${PREFIX}/bin/
+ ${INSTALL_LIB} ${WRKSRC}/libpkcs11-gateway.so.1 ${PREFIX}/lib/
+ cd ${PREFIX}/lib && ${LN} -sf libpkcs11-gateway.so.1 \
+ libpkcs11-gateway.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/pkcs11-gateway/distinfo b/security/pkcs11-gateway/distinfo
new file mode 100644
index 000000000000..6d90f2590ee9
--- /dev/null
+++ b/security/pkcs11-gateway/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pkcs11-gateway-1.0.tar.gz) = d8eb5931aa3faf9e68c1e8d0dbe8f4e7e7362b0bc48bf0d61de9f89c42428260
+SIZE (pkcs11-gateway-1.0.tar.gz) = 68482
diff --git a/security/pkcs11-gateway/pkg-descr b/security/pkcs11-gateway/pkg-descr
new file mode 100644
index 000000000000..5587afb96496
--- /dev/null
+++ b/security/pkcs11-gateway/pkg-descr
@@ -0,0 +1,9 @@
+pkcs11-gateway is a software that allows you to use a Linux 32-bit PKCS#11
+module on FreeBSD i386/amd64.
+It consists of a FreeBSD Cryptoki wrapper library that serializes and forwards
+PKCS#11 function calls to a Linux server program that dlopen() and use the
+real module. The communication between the two components is via a UNIX socket.
+pkcs11-gateway is based on the rpc-layer of Gnome Keyring.
+
+- Alex Dupre
+ale@FreeBSD.org