aboutsummaryrefslogtreecommitdiff
path: root/security/pks
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-12-09 03:34:53 +0000
committerSteve Wills <swills@FreeBSD.org>2018-12-09 03:34:53 +0000
commitba71c7b21a826eadf5200b9c77b092b7655aba6c (patch)
treec6bf3193810f04cbc101f0083a5a6a63cc5962b5 /security/pks
parent8f1ddd0432a0ace199623e08af21d130f5a006cd (diff)
downloadports-ba71c7b21a826eadf5200b9c77b092b7655aba6c.tar.gz
ports-ba71c7b21a826eadf5200b9c77b092b7655aba6c.zip
security/pks: mark build with openssl 1.1 as broken
PR: 233848 Submitted by: Tassilo Philipp <tphilipp@potion-studios.com> (maintainer)
Notes
Notes: svn path=/head/; revision=487018
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 5f6102a7e401..772c77aa1bb6 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -14,12 +14,15 @@ COMMENT= PGP Public Key Server
LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-WRKSRC= ${WRKDIR}/${PORTNAME}
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= member access into incomplete type 'EVP_PKEY' (aka 'evp_pkey_st')
USES= bdb ssl
USE_GCC= any
USE_RC_SUBR= pksd
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} \
--localstatedir=/var/pks \
@@ -49,4 +52,10 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base
+BROKEN= Does not build with OpenSSL 1.1
+.endif
+
.include <bsd.port.mk>