aboutsummaryrefslogtreecommitdiff
path: root/security/pks
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-01-01 20:01:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-01-01 20:01:08 +0000
commitc32e901fd089045d493fe53d0444e2e2506d7efa (patch)
tree60af385b512cab7b438e8a86edfa309e1cb92673 /security/pks
parent249552cac0bd189727c0c98706aa215ad6ce4b3c (diff)
downloadports-c32e901fd089045d493fe53d0444e2e2506d7efa.tar.gz
ports-c32e901fd089045d493fe53d0444e2e2506d7efa.zip
- Patch configure instead of configure.in so USE_AUTOTOOLS can be removed.
- Remove unneeded --docdir, --sysconfdir and --libdir from CONFIGURE_ARGS. - Remove unused RESETPREFIX. - Remove pkg-install because it's already handled by pkg-plist. - Use @sample.
Notes
Notes: svn path=/head/; revision=457793
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile14
-rw-r--r--security/pks/files/patch-configure (renamed from security/pks/files/patch-configure.in)55
-rw-r--r--security/pks/pkg-install22
-rw-r--r--security/pks/pkg-plist3
4 files changed, 41 insertions, 53 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 3ef0ece127f2..68e4c73f5312 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pks
PORTVERSION= 0.9.6.20040312
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security www
MASTER_SITES= http://pks.sourceforge.net/ LOCAL/mandree
DISTFILES= pks-current.tgz
@@ -22,10 +22,9 @@ USES= bdb ssl
OPTIONS_DEFINE= DOCS
PORTDOCS= pks_help.* README EMAIL
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf
-CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
- --docdir=${PREFIX}/share/doc/pks --sysconfdir=${EXAMPLESDIR} \
- --libdir=${LOCALBASE}/lib --with-libwrap \
+CONFIGURE_ARGS= --datadir=${DATADIR} \
+ --localstatedir=/var/pks \
+ --with-libwrap \
--with-openssl=${OPENSSLBASE}
MAKE_ENV+= SUBDIRS=
LDFLAGS+= -L${LOCALBASE}/lib
@@ -35,8 +34,6 @@ CONFIGURE_ENV= DBLIB="-L${BDB_LIB_DIR} -l${BDB_LIB_NAME}" \
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_SUB+= RESETPREFIX=${PREFIX}
-
USE_RC_SUBR= pksd
post-extract:
@@ -47,8 +44,7 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pksdctl
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pksclient
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/pksd
- ${INSTALL_DATA} ${WRKSRC}/pksd.conf ${STAGEDIR}${PREFIX}/etc/pksd.conf.sample
- #${CHOWN} pksd:pksd /var/pks
+ ${MV} ${STAGEDIR}${PREFIX}/etc/pksd.conf ${STAGEDIR}${PREFIX}/etc/pksd.conf.sample
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
diff --git a/security/pks/files/patch-configure.in b/security/pks/files/patch-configure
index 39a93721326d..ea4c6d634acb 100644
--- a/security/pks/files/patch-configure.in
+++ b/security/pks/files/patch-configure
@@ -1,21 +1,28 @@
---- ./configure.in.orig 2004-01-18 00:19:56.000000000 +0100
-+++ ./configure.in 2014-08-15 18:32:37.000000000 +0200
-@@ -74,126 +74,6 @@
+--- configure.orig 2004-01-17 23:19:56 UTC
++++ configure
+@@ -2530,141 +2530,6 @@ echo "${ECHO_T}Compiler Optimizations Enabled" >&6
+ fi;
+
# Checks for libraries.
- dnl Checks for Berkeley DB
- AC_MSG_CHECKING(for Berkeley DB)
--AC_ARG_WITH(db,
--[ --with-db=DIR Use Berkeley DB in DIR],
--[DBINC=NO
+-echo "$as_me:$LINENO: checking for Berkeley DB" >&5
+-echo $ECHO_N "checking for Berkeley DB... $ECHO_C" >&6
+-
+-# Check whether --with-db or --without-db was given.
+-if test "${with_db+set}" = set; then
+- withval="$with_db"
+- DBINC=NO
- DBLIB=NO
- DBHDR=NO
- S=1
- case "$withval" in
- yes|no)
-- AC_ERROR(Berkeley DB was not found. Please check your installation or use --with-db=PATH)
+- { { echo "$as_me:$LINENO: error: Berkeley DB was not found. Please check your installation or use --with-db=PATH" >&5
+-echo "$as_me: error: Berkeley DB was not found. Please check your installation or use --with-db=PATH" >&2;}
+- { (exit 1); exit 1; }; }
- ;;
- *)
-- AC_MSG_RESULT($withval)
+- echo "$as_me:$LINENO: result: $withval" >&5
+-echo "${ECHO_T}$withval" >&6
- if test x${withval} = x ; then
- withval=/tmp
- fi
@@ -60,11 +67,15 @@
- S=$?
- fi
- if test $S -eq 1 ; then
-- AC_ERROR(Berkeley DB was not found. Please check your installation or use --with-db=DIR)
+- { { echo "$as_me:$LINENO: error: Berkeley DB was not found. Please check your installation or use --with-db=DIR" >&5
+-echo "$as_me: error: Berkeley DB was not found. Please check your installation or use --with-db=DIR" >&2;}
+- { (exit 1); exit 1; }; }
- fi
-- AC_MSG_RESULT(yes)
-- esac ],
--[DBINC=NO
+- echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+- esac
+-else
+- DBINC=NO
- DBLIB=NO
- DBHDR=NO
- S=1
@@ -120,10 +131,14 @@
- fi
-
- if test $S -eq 1 ; then
-- AC_ERROR(Berkeley DB was not found. Please check your installation or use --with-db=DIR)
+- { { echo "$as_me:$LINENO: error: Berkeley DB was not found. Please check your installation or use --with-db=DIR" >&5
+-echo "$as_me: error: Berkeley DB was not found. Please check your installation or use --with-db=DIR" >&2;}
+- { (exit 1); exit 1; }; }
- fi
-- AC_MSG_RESULT(yes) ]
--)
- AC_SUBST(DBINC)
- AC_SUBST(DBLIB)
- AC_SUBST(DBHDR)
+- echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+-
+-fi;
+
+
+
diff --git a/security/pks/pkg-install b/security/pks/pkg-install
deleted file mode 100644
index ae5534f0e2ae..000000000000
--- a/security/pks/pkg-install
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-PKGNAME=$1
-STAGE=$2
-
-case ${STAGE} in
-PRE-INSTALL)
- ;;
-POST-INSTALL)
- DBDIR=/var/pks/db
- MAILDIR=/var/pks/incoming
-
- mkdir -p ${DBDIR} ${MAILDIR}
- ;;
-*)
- echo "Unexpected argument: ${STAGE}"
- exit 1
- ;;
-esac
-exit 0
diff --git a/security/pks/pkg-plist b/security/pks/pkg-plist
index 2f92f2c9f896..a74ab5171c51 100644
--- a/security/pks/pkg-plist
+++ b/security/pks/pkg-plist
@@ -4,11 +4,10 @@ bin/pks-queue-run.sh
bin/pksclient
sbin/pksd
bin/pksdctl
-etc/pksd.conf.sample
+@sample etc/pksd.conf.sample
%%DATADIR%%/mail_intro
%%DATADIR%%/pks-commands.html
%%DATADIR%%/pks-commands.php
-%%EXAMPLESDIR%%/pksd.conf
man/man5/pksd.conf.5.gz
man/man8/pgpsplit.8.gz
man/man8/pks-intro.8.gz