aboutsummaryrefslogtreecommitdiff
path: root/security/pks
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-11 06:08:44 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-11 06:08:44 +0000
commited4a11e32610e28af7200c373aa48266d5e7e2c5 (patch)
treee6bfb8e0bc791241eceee768530a7bd057982640 /security/pks
parentb3d513d467bc6dd02cfab5f6470621e879be6269 (diff)
downloadports-ed4a11e32610e28af7200c373aa48266d5e7e2c5.tar.gz
ports-ed4a11e32610e28af7200c373aa48266d5e7e2c5.zip
security/pks: Document SSL requirement and configure SSL base correctly
Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=421800
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 9f73c9d8d914..73f871e99d86 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GCC= any
-USES= bdb
+USES= bdb ssl
OPTIONS_DEFINE= DOCS
PORTDOCS= pks_help.* README EMAIL
@@ -25,10 +25,12 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
--docdir=${PREFIX}/share/doc/pks --sysconfdir=${EXAMPLESDIR} \
- --libdir=${LOCALBASE}/lib --with-libwrap
+ --libdir=${LOCALBASE}/lib --with-libwrap \
+ --with-openssl=${OPENSSLBASE}
MAKE_ENV+= SUBDIRS=
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= DBLIB="-L${BDB_LIB_DIR} -l${BDB_LIB_NAME}" DBINC=-I${BDB_INCLUDE_DIR} DBHDR=db.h
+CONFIGURE_ENV= DBLIB="-L${BDB_LIB_DIR} -l${BDB_LIB_NAME}" \
+ DBINC=-I${BDB_INCLUDE_DIR} DBHDR=db.h
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message