aboutsummaryrefslogtreecommitdiff
path: root/security/ppars
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2005-02-07 14:53:28 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2005-02-07 14:53:28 +0000
commit51fdd4cbc974b0c2ccb49eab77894e0514d77e80 (patch)
tree11a88b2727c7697ec496e5a47e27b102af94d53c /security/ppars
parentd637d2c31f0abe5afce572c57839012028c4ad1f (diff)
downloadports-51fdd4cbc974b0c2ccb49eab77894e0514d77e80.tar.gz
ports-51fdd4cbc974b0c2ccb49eab77894e0514d77e80.zip
Add security/ppars - Proactive Abuse Reporting System:
In an effort to be proactive in doing my part to stop the massive quantities of internet traffic probing for open ports or more specifically the probing for known ports that MS Windows spyware, Trojans, and whatever other MS Windows ports are commonly probed which result in increasing my bandwidth usage charges, I wrote this perl application for reporting that abuse to the sender's ISP, with the hopes they will monitor the abuser and terminate the abuser's internet account and or take legal action. WWW: http://www.dshield.org/linux_clients.php#freebsd Author: Joe Barbish <fbsd_user@a1poweruser.com> PR: ports/68662 Submitted by: Joe Barbish <fbsd_user@a1poweruser.com>
Notes
Notes: svn path=/head/; revision=128231
Diffstat (limited to 'security/ppars')
-rw-r--r--security/ppars/Makefile36
-rw-r--r--security/ppars/distinfo2
-rw-r--r--security/ppars/files/pkg-message.in27
-rw-r--r--security/ppars/pkg-descr24
-rw-r--r--security/ppars/pkg-plist7
5 files changed, 96 insertions, 0 deletions
diff --git a/security/ppars/Makefile b/security/ppars/Makefile
new file mode 100644
index 000000000000..893cca121dfc
--- /dev/null
+++ b/security/ppars/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ppars
+# Date created: 2004-06-29
+# Whom: Joe Barbish <fbsd_user@a1poweruser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ppars
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://www.dshield.org/clients/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= fbsd_user@a1poweruser.com
+COMMENT= Proactive Probing Abuse Reporting System
+
+RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+
+USE_PERL5= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 490000
+IGNORE= "Not supported on releases prior to 4.9"
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${PREFIX}/sbin
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/security/ppars/distinfo b/security/ppars/distinfo
new file mode 100644
index 000000000000..fe3cffd4ce06
--- /dev/null
+++ b/security/ppars/distinfo
@@ -0,0 +1,2 @@
+MD5 (ppars.tar.gz) = f7bc273d85dd28e71d2efa8a2551c05a
+SIZE (ppars.tar.gz) = 13219
diff --git a/security/ppars/files/pkg-message.in b/security/ppars/files/pkg-message.in
new file mode 100644
index 000000000000..93b6a8111e28
--- /dev/null
+++ b/security/ppars/files/pkg-message.in
@@ -0,0 +1,27 @@
+***************************************************************************
+
+Installer instructions. This port has installed the following six
+scripts into %%PREFIX%%/sbin directory.
+ abuse.dshield.pl
+ abuse.ipflog.rotate.pl
+ abuse.myisp.pl
+ abuse.public.ISP0.pl
+ abuse.public.ISP1.pl
+ abuse.Reporting.system.pl
+
+You have to edit the scripts and change the default email address in
+the script source. Script contains comments explaining what needs to
+be changed. In some cases you also have to create an exclude file,
+follow instructions in the individual scripts about the syntax of
+the exclude file contents.
+
+To receive feedback reports and see your abuse.dshield.pl submitted
+log data online at dshield.org you have to sign up for free
+membership. See www.dshield.org for details.
+
+First issue rehash command and then run abuse.Reporting.system.pl
+it contains an overview of how the system works and how to setup the
+ipfilter log so when it's rotated all the scripts will be auto
+launched.
+
+***************************************************************************
diff --git a/security/ppars/pkg-descr b/security/ppars/pkg-descr
new file mode 100644
index 000000000000..3c3de2c4e79a
--- /dev/null
+++ b/security/ppars/pkg-descr
@@ -0,0 +1,24 @@
+Welcome to the Proactive Abuse Reporting System.
+
+In an effort to be proactive in doing my part to stop the massive
+quantities of internet traffic probing for open ports or more
+specifically the probing for known ports that ms/windows spy ware,
+Trojans, and what ever other ms/windows ports are commonly probed
+which result in increasing my bandwidth usage changes, I wrote this
+perl application for reporting that abuse to the senders ISP, with
+the hopes they will monitor the abuser and terminate the abuser's
+internet account and or take legal action.
+
+Script is installed into /usr/local/sbin where you can edit the
+defaults to meet your requirements. Issue rehash command to enable.
+Run abuse.Reporting.system.pl script for complete overview description
+of system.
+
+6/1/2004 Author: Joe Barbish, I bequeath these perl scripts to public
+domain. It can be copied and distributed for free by anyone to anyone
+by any manner.
+
+WWW: http://www.dshield.org/linux_clients.php#freebsd
+
+Joe Barbish
+fbsd_user@a1poweruser.com
diff --git a/security/ppars/pkg-plist b/security/ppars/pkg-plist
new file mode 100644
index 000000000000..2a081c1da449
--- /dev/null
+++ b/security/ppars/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+sbin/abuse.Reporting.system.pl
+sbin/abuse.dshield.pl
+sbin/abuse.ipflog.rotate.pl
+sbin/abuse.myisp.pl
+sbin/abuse.public.ISP0.pl
+sbin/abuse.public.ISP1.pl