aboutsummaryrefslogtreecommitdiff
path: root/security/proxytunnel
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-19 21:34:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-19 21:34:56 +0000
commitf6d11cbc9e318b89f4e34c3dd99a9c5cfa2f9fc8 (patch)
tree7564a03150ddceac677af25915cb8aebb665febc /security/proxytunnel
parent0d245b9d02055935bab8a10d3621640a7452e6ac (diff)
downloadports-f6d11cbc9e318b89f4e34c3dd99a9c5cfa2f9fc8.tar.gz
ports-f6d11cbc9e318b89f4e34c3dd99a9c5cfa2f9fc8.zip
Fix SSL support.
Notified by: Nagilum <nagilum@nagilum.org>
Notes
Notes: svn path=/head/; revision=157683
Diffstat (limited to 'security/proxytunnel')
-rw-r--r--security/proxytunnel/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/proxytunnel/Makefile b/security/proxytunnel/Makefile
index b8ad670da141..29c7c43c561d 100644
--- a/security/proxytunnel/Makefile
+++ b/security/proxytunnel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proxytunnel
PORTVERSION= 1.6.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,8 +23,16 @@ ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/proxytunnel
PORTDOCS= CHANGES CREDITS README
+CFLAGS+= -DUSE_SSL -DSETPROCTITLE -DSPT_TYPE=1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+CFLAGS+= -DHAVE_GETOPT_LONG
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e '/^CFLAGS*/d; /^CC*/d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
@@ -35,4 +44,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>