aboutsummaryrefslogtreecommitdiff
path: root/security/putty
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-03-16 23:39:58 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-03-16 23:39:58 +0000
commitcb5474eff307127ee985793b53ae91232d312670 (patch)
tree62c13d531627b7f2bc7246b5008ea07d4b10be1a /security/putty
parent3180fead43785faf5a17519de5845c7ec1b0a4e6 (diff)
downloadports-cb5474eff307127ee985793b53ae91232d312670.tar.gz
ports-cb5474eff307127ee985793b53ae91232d312670.zip
Update to new upstream release 0.68 (security fixes)
Additional minor updates on top of cy@'s patch (USE_GNOME, USE_XORG, LDFLAGS). ChangeLog: http://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html Submitted by: cy@ MFH: 2017Q1 Security: CVE-2017-6542 Security: 9b973e97-0a99-11e7-ace7-080027ef73ec Differential Revision: https://reviews.freebsd.org/D10023
Notes
Notes: svn path=/head/; revision=436313
Diffstat (limited to 'security/putty')
-rw-r--r--security/putty/Makefile7
-rw-r--r--security/putty/distinfo5
-rw-r--r--security/putty/files/patch-Makefile.gtk21
3 files changed, 19 insertions, 14 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index caa6fb7ba8f9..3cbe19cb2028 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= putty
-PORTVERSION= 0.67
+PORTVERSION= 0.68
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/${PORTVERSION}/ \
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
@@ -31,9 +31,12 @@ CONFLICTS_INSTALL?= pssh-[0-9]* putty-nogtk-[0-9]*
.include <bsd.port.options.mk>
CFLAGS+= -DBSD_PTYS -DOMIT_UTMP -DIPV6
+LDFLAGS+= -Wl,--as-needed
.if ${PORT_OPTIONS:MGTK2} && !defined(WITHOUT_X11)
-USE_GNOME= gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_XORG= x11
+
PLIST_FILES+= bin/pterm bin/putty bin/puttytel
PLIST_FILES+= man/man1/pterm.1.gz man/man1/putty.1.gz man/man1/puttytel.1.gz
MAKE_ARGS+= PUTTY_WITH_GTK=yes GTK_CONFIG="pkg-config gtk+-2.0 x11 --cflags"
diff --git a/security/putty/distinfo b/security/putty/distinfo
index 2c78b62483d0..213a8f1d8701 100644
--- a/security/putty/distinfo
+++ b/security/putty/distinfo
@@ -1,2 +1,3 @@
-SHA256 (putty-0.67.tar.gz) = 80192458e8a46229de512afeca5c757dd8fce09606b3c992fbaeeee29b994a47
-SIZE (putty-0.67.tar.gz) = 1955547
+TIMESTAMP = 1489606314
+SHA256 (putty-0.68.tar.gz) = 7ba256f46e5a353cafe811ce7914d0e22a52bdfc0e6e2d183ad28b5af44cd09c
+SIZE (putty-0.68.tar.gz) = 2114499
diff --git a/security/putty/files/patch-Makefile.gtk b/security/putty/files/patch-Makefile.gtk
index b3d47c821323..976af7dce204 100644
--- a/security/putty/files/patch-Makefile.gtk
+++ b/security/putty/files/patch-Makefile.gtk
@@ -1,27 +1,28 @@
---- Makefile.gtk.orig 2015-02-28 15:33:27 UTC
-+++ Makefile.gtk
-@@ -110,7 +110,7 @@ GTK_CONFIG = sh -c 'pkg-config gtk+-2.0
+--- Makefile.gtk.orig 2017-03-16 02:47:16.000000000 +0000
++++ Makefile.gtk 2017-03-16 02:47:16.000000000 +0000
+@@ -111,7 +111,7 @@
unexport CFLAGS # work around a weird issue with krb5-config
-CFLAGS = -O2 -Wall -Werror -g -I.././ -I../charset/ -I../windows/ -I../unix/ \
+CFLAGS := $(CFLAGS) -Wall -Werror -I.././ -I../charset/ -I../windows/ -I../unix/ \
- -I../macosx/ $(shell $(GTK_CONFIG) --cflags) -D _FILE_OFFSET_BITS=64
+ $(shell $(GTK_CONFIG) --cflags) -D _FILE_OFFSET_BITS=64
XLDFLAGS = $(LDFLAGS) $(shell $(GTK_CONFIG) --libs)
ULDFLAGS = $(LDFLAGS)
-@@ -137,7 +137,11 @@ man1dir=$(mandir)/man1
+@@ -138,8 +138,12 @@
.SUFFIXES:
+ifdef PUTTY_WITH_GTK
- all: plink pscp psftp pterm putty puttygen puttytel
+ all: cgtest fuzzterm osxlaunch pageant plink pscp psftp pterm ptermapp putty \
+ puttyapp puttygen puttytel testbn
+else
+all: plink pscp psftp puttygen
+endif
- plink: be_all_s.o callback.o cmdline.o conf.o cproxy.o ldisc.o logging.o \
- misc.o noterm.o pgssapi.o pinger.o portfwd.o proxy.o raw.o \
-@@ -920,6 +924,8 @@ install:
+ cgtest: cgtest.o conf.o import.o misc.o notiming.o sshaes.o sshbcrypt.o \
+ sshblowf.o sshbn.o sshdes.o sshdss.o sshdssg.o sshecc.o \
+@@ -1050,6 +1054,8 @@
$(INSTALL_PROGRAM) -m 755 plink $(DESTDIR)$(bindir)/plink
$(INSTALL_PROGRAM) -m 755 pscp $(DESTDIR)$(bindir)/pscp
$(INSTALL_PROGRAM) -m 755 psftp $(DESTDIR)$(bindir)/psftp
@@ -30,7 +31,7 @@
$(INSTALL_PROGRAM) -m 755 pterm $(DESTDIR)$(bindir)/pterm
if test -n "$(UTMP_GROUP)"; then \
chgrp $(UTMP_GROUP) $(DESTDIR)$(bindir)/pterm && \
-@@ -929,15 +935,17 @@ install:
+@@ -1059,15 +1065,17 @@
chmod 4755 $(DESTDIR)$(bindir)/pterm; \
fi
$(INSTALL_PROGRAM) -m 755 putty $(DESTDIR)$(bindir)/putty