aboutsummaryrefslogtreecommitdiff
path: root/security/pwauth
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-10-14 08:39:54 +0000
committerClement Laforet <clement@FreeBSD.org>2004-10-14 08:39:54 +0000
commit98c26311be5ec602ed7fae65315198360d872f53 (patch)
treeb9a2c2014297c550ab40b97e337afa1495bb97fc /security/pwauth
parenta68d37a4ff8d66ba81467d946dc7b4a4855657dd (diff)
downloadports-98c26311be5ec602ed7fae65315198360d872f53.tar.gz
ports-98c26311be5ec602ed7fae65315198360d872f53.zip
Add security/pwauth 2.2.8,
A Unix Web Authenticator.
Notes
Notes: svn path=/head/; revision=119382
Diffstat (limited to 'security/pwauth')
-rw-r--r--security/pwauth/Makefile30
-rw-r--r--security/pwauth/distinfo2
-rw-r--r--security/pwauth/files/patch-Makefile22
-rw-r--r--security/pwauth/files/patch-config.c34
-rw-r--r--security/pwauth/files/patch-pwauth.c11
-rw-r--r--security/pwauth/pkg-descr5
6 files changed, 104 insertions, 0 deletions
diff --git a/security/pwauth/Makefile b/security/pwauth/Makefile
new file mode 100644
index 000000000000..7fb5349885e2
--- /dev/null
+++ b/security/pwauth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pwauth
+# Date created: Oct 14 2004
+# Whom: clement
+#
+# $FreeBSD$
+#
+
+PORTNAME= pwauth
+PORTVERSION= 2.2.8
+CATEGORIES= security www
+MASTER_SITES= http://www.unixpapa.com/software/
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= A Unix Web Authenticator
+
+USE_REINPLACE= yes
+PLIST_FILES= bin/pwauth
+
+.include <bsd.port.pre.mk>
+
+WWWUID!= ${ID} -u ${WWWOWN}
+
+post-patch:
+ @${REINPLACE_CMD} "s/%%UIDS%%/${WWWUID}/ ; \
+ s/%%MINUID%%/1000/" ${WRKSRC}/config.h
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/pwauth ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/security/pwauth/distinfo b/security/pwauth/distinfo
new file mode 100644
index 000000000000..feac78bdcddf
--- /dev/null
+++ b/security/pwauth/distinfo
@@ -0,0 +1,2 @@
+MD5 (pwauth-2.2.8.tar.gz) = 1cdeeea6b7fd9b5cd72c455b9a9e32be
+SIZE (pwauth-2.2.8.tar.gz) = 13965
diff --git a/security/pwauth/files/patch-Makefile b/security/pwauth/files/patch-Makefile
new file mode 100644
index 000000000000..d9a6b56dbb52
--- /dev/null
+++ b/security/pwauth/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Thu Oct 14 10:01:13 2004
++++ Makefile Thu Oct 14 10:09:38 2004
+@@ -6,9 +6,7 @@
+ # LOCALFLAGS= compiler flags. Usually -g, -O, and stuff like that.
+
+ # Settings for author's system (Redhat 6.1)
+-CC=gcc
+-LIB= -lcrypt
+-LOCALFLAGS= -g
++LIB= -lcrypt -lpam
+
+ # For PAM on Redhat Linux
+ # LIB=-lpam -ldl
+@@ -18,7 +16,7 @@
+
+ # -------------------- No User Servicable Parts Below -----------------------
+
+-CFLAGS= $(LOCALFLAGS)
++all: pwauth
+
+ pwauth: pwauth.o
+ $(CC) -o pwauth $(CFLAGS) pwauth.o $(LIB)
diff --git a/security/pwauth/files/patch-config.c b/security/pwauth/files/patch-config.c
new file mode 100644
index 000000000000..f92d8c739107
--- /dev/null
+++ b/security/pwauth/files/patch-config.c
@@ -0,0 +1,34 @@
+--- config.h.orig Thu Oct 14 10:18:19 2004
++++ config.h Thu Oct 14 10:17:07 2004
+@@ -93,11 +93,11 @@
+
+ /* #define SHADOW_NONE /**/
+ /* #define SHADOW_BSD /**/
+-#define SHADOW_SUN /**/
++/* #define SHADOW_SUN /**/
+ /* #define SHADOW_JFH /**/
+ /* #define SHADOW_MDW /**/
+ /* #define SHADOW_AIX /**/
+-/* #define PAM /**/
++#define PAM /**/
+ /* #define PAM_SOLARIS_26 /**/
+
+
+@@ -145,7 +145,7 @@
+ * last).
+ */
+
+-#define SERVER_UIDS 99 /* user "nobody" */
++#define SERVER_UIDS %%UIDS%% /* user "nobody" */
+
+
+ /* If MIN_UNIX_UID is defined to an integer, logins with uid numbers less than
+@@ -156,7 +156,7 @@
+ * given value will be accepted).
+ */
+
+-#define MIN_UNIX_UID 500 /**/
++#define MIN_UNIX_UID %%MINUID%% /**/
+
+
+ /* On failed authentications, pwauth will sleep for SLEEP_TIME seconds, using
diff --git a/security/pwauth/files/patch-pwauth.c b/security/pwauth/files/patch-pwauth.c
new file mode 100644
index 000000000000..669ad82fa182
--- /dev/null
+++ b/security/pwauth/files/patch-pwauth.c
@@ -0,0 +1,11 @@
+--- pwauth.c.orig Thu Oct 14 10:23:59 2004
++++ pwauth.c Thu Oct 14 10:24:11 2004
+@@ -141,7 +141,7 @@
+ #ifdef UNIX_LASTLOG
+ #define NEED_UID
+ #include <utmp.h>
+-#include <lastlog.h>
++//#include <lastlog.h>
+ #ifndef UT_LINESIZE
+ #define UT_LINESIZE 8
+ #endif
diff --git a/security/pwauth/pkg-descr b/security/pwauth/pkg-descr
new file mode 100644
index 000000000000..e1287de75859
--- /dev/null
+++ b/security/pwauth/pkg-descr
@@ -0,0 +1,5 @@
+Pwauth is an authenticator designed to be used with mod_auth_external
+and the Apache HTTP Daemon to support reasonably secure web authentication
+out of the system password database on most versions of Unix.
+
+WWW: http://www.unixpapa.com/pwauth/