aboutsummaryrefslogtreecommitdiff
path: root/security/pwman/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-14 20:16:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-14 20:16:45 +0000
commit4cc48499fbb6daa189c320e1f700801478996332 (patch)
treeae9a946c613eb3d7ef77cc00a83faa15c83a1678 /security/pwman/Makefile
parent7b72e3a1f4e6541085be6a0999e8af54a54743dc (diff)
Notes
Diffstat (limited to 'security/pwman/Makefile')
-rw-r--r--security/pwman/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index 7ba61cd2bffe..8816749aac8d 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= pwman
-PORTVERSION= 0.3.8
-PORTREVISION= 1
+PORTVERSION= 0.3.9
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= anders@FreeBSD.org
COMMENT= Console password management application based on gpg(me)
@@ -20,9 +18,11 @@ RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
GNU_CONFIGURE= yes
-MAN1= pwman.1
+MAN1= pwman.1
-DOCS= AUTHORS COPYING ChangeLog README TODO
+PLIST_FILES= bin/convert_pwdb bin/pwdb2csv bin/pwman
+
+PORTDOCS= AUTHORS COPYING ChangeLog README TODO
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/gpg|${LOCALBASE}/bin/gpg|g' ${WRKSRC}/src/options.c
@@ -30,9 +30,7 @@ post-patch:
.if !defined(NOPORTDOCS)
post-install:
@${INSTALL} -d -m 0755 ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>