aboutsummaryrefslogtreecommitdiff
path: root/security/pwman
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-03 22:27:14 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-03 22:27:14 +0000
commit76cac70f532b59e1a1ab9faf1af5c1567ffd3d81 (patch)
tree99d39a613c6851a239e460593d7e57a71b5be8e0 /security/pwman
parentc64bc83de5e5ff317c8fc7bfefcd9dbc7e22c566 (diff)
downloadports-76cac70f532b59e1a1ab9faf1af5c1567ffd3d81.tar.gz
ports-76cac70f532b59e1a1ab9faf1af5c1567ffd3d81.zip
security/pwman: document ncurses requirement (USES+=ncurses)
Also link with libncurses, not libcurses
Notes
Notes: svn path=/head/; revision=407998
Diffstat (limited to 'security/pwman')
-rw-r--r--security/pwman/Makefile2
-rw-r--r--security/pwman/files/patch-configure28
2 files changed, 30 insertions, 0 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index ed223f08fc65..1f97812b9ba6 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -14,8 +14,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
+USES= ncurses
USE_GNOME= libxml2
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= curses_loc=${NCURSESBASE}
PORTDOCS= AUTHORS ChangeLog README TODO
PLIST_FILES= bin/convert_pwdb bin/pwdb2csv bin/pwman man/man1/pwman.1.gz
diff --git a/security/pwman/files/patch-configure b/security/pwman/files/patch-configure
new file mode 100644
index 000000000000..008150831810
--- /dev/null
+++ b/security/pwman/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig 2011-02-15 22:30:29 UTC
++++ configure
+@@ -4339,13 +4339,13 @@ if test "${with_curses+set}" = set; then
+ fi
+
+
+-{ echo "$as_me:$LINENO: checking for initscr in -lcurses" >&5
+-echo $ECHO_N "checking for initscr in -lcurses... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking for initscr in -lncurses" >&5
++echo $ECHO_N "checking for initscr in -lncurses... $ECHO_C" >&6; }
+ if test "${ac_cv_lib_curses_initscr+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcurses $LIBS"
++LIBS="-lncurses $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -4401,7 +4401,7 @@ fi
+ { echo "$as_me:$LINENO: result: $ac_cv_lib_curses_initscr" >&5
+ echo "${ECHO_T}$ac_cv_lib_curses_initscr" >&6; }
+ if test $ac_cv_lib_curses_initscr = yes; then
+- LIBS="$LIBS -lcurses"
++ LIBS="$LIBS -lncurses"
+ if test x$curses_loc = x/usr -a -d /usr/include/ncurses; then
+ CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
+ fi