aboutsummaryrefslogtreecommitdiff
path: root/security/pwman
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-11 14:25:55 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-11 14:25:55 +0000
commitfcfa9264019a59cf20f499121fe7e3b86f95f437 (patch)
treef0c7c3bde1afa93a810e17f4db078e59c0f31181 /security/pwman
parent0dfae74d70e58c042bccd36e495a21b71d92a6f2 (diff)
Notes
Diffstat (limited to 'security/pwman')
-rw-r--r--security/pwman/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index f69f3ce6d8a7..55e7a8136a73 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Console password management application based on gpg(me)
LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
@@ -15,20 +15,18 @@ RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
GNU_CONFIGURE= yes
-MAN1= pwman.1
-
-PLIST_FILES= bin/convert_pwdb bin/pwdb2csv bin/pwman
+CFLAGS+= -Wno-return-type
+PLIST_FILES= bin/convert_pwdb bin/pwdb2csv bin/pwman man/man1/pwman.1.gz
PORTDOCS= AUTHORS COPYING ChangeLog README TODO
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/gpg|${LOCALBASE}/bin/gpg|g' ${WRKSRC}/src/options.c
-.if !defined(NOPORTDOCS)
post-install:
- @${INSTALL} -d -m 0755 ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>