aboutsummaryrefslogtreecommitdiff
path: root/security/pwned-check
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2018-02-23 22:50:01 +0000
committerStefan Eßer <se@FreeBSD.org>2018-02-23 22:50:01 +0000
commit70da189e67bda3a947acd205ab104b7ada3a573c (patch)
tree5e9fd599e856f419de3d62e5528a55a2cec314f0 /security/pwned-check
parent786cc765aa3f88132596103551a3f29c98da92d9 (diff)
downloadports-70da189e67bda3a947acd205ab104b7ada3a573c.tar.gz
ports-70da189e67bda3a947acd205ab104b7ada3a573c.zip
Revert previous commit. The format of the passwort hash database files
has been changed and entries are no longer sorted. PORTEPOCH is not incremented, since only a few minutes passed after the commit of the revoked upate. Approved by: antoine (implicit)
Notes
Notes: svn path=/head/; revision=462752
Diffstat (limited to 'security/pwned-check')
-rw-r--r--security/pwned-check/Makefile2
-rw-r--r--security/pwned-check/files/pkg-message.in4
-rw-r--r--security/pwned-check/files/pwned-check.1.in7
-rw-r--r--security/pwned-check/files/pwned-check.conf.sample2
-rw-r--r--security/pwned-check/files/pwned-check.sh.in6
5 files changed, 10 insertions, 11 deletions
diff --git a/security/pwned-check/Makefile b/security/pwned-check/Makefile
index adb347ebce29..383fa3bbc4d9 100644
--- a/security/pwned-check/Makefile
+++ b/security/pwned-check/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pwned-check
-PORTVERSION= 2.0
+PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= #
DISTFILES= #
diff --git a/security/pwned-check/files/pkg-message.in b/security/pwned-check/files/pkg-message.in
index bc33265f32c9..14baaa982e9f 100644
--- a/security/pwned-check/files/pkg-message.in
+++ b/security/pwned-check/files/pkg-message.in
@@ -7,7 +7,7 @@ the following command:
The database files will be installed into /var/db/pwned-check by default.
This directory can be changed in %%PREFIX%%/etc/pwned-check.conf.
-The installation procedure will fetch 9 GB of compressed data and will
-temporarily need 40 GB of free space in that directory and 30 GB when
+The installation procedure will fetch 6 GB of compressed data and will
+temporarily need 18 GB of free space in that directory and 13 GB when
the installation is complete.
-------------------------------------------------------------------------
diff --git a/security/pwned-check/files/pwned-check.1.in b/security/pwned-check/files/pwned-check.1.in
index a5ed230ff08d..9c0a51a49608 100644
--- a/security/pwned-check/files/pwned-check.1.in
+++ b/security/pwned-check/files/pwned-check.1.in
@@ -29,9 +29,8 @@ plain text password corresponding to a given SHA1 hash.
.Pp
If the option
.Fl u
-is used, the password hash database (9 GB compressed) is downloaded and
-initialized.
-This process will temporarily require some 40 GB of free space in the
+is used, the password hash database is downloaded and initialized.
+This process will temporarily require some 18 GB of free space in the
database directory, which is
.Pa /var/db/pwned-check
by default.
@@ -43,7 +42,7 @@ the download.
Optional configuration file.
.It Pa /var/db/pwned-check
Default location of pwned password hash database.
-Needs up to 40 GB of free space during download, 30 GB when finished.
+Needs 18 GB of free space during download, 13 GB when finished.
.El
.Sh EXIT STATUS
.Nm
diff --git a/security/pwned-check/files/pwned-check.conf.sample b/security/pwned-check/files/pwned-check.conf.sample
index b754d46816f0..9cb40488b876 100644
--- a/security/pwned-check/files/pwned-check.conf.sample
+++ b/security/pwned-check/files/pwned-check.conf.sample
@@ -1,2 +1,2 @@
DBDIR= /var/db/pwned-check
-URLBASE= https://downloads.pwnedpasswords.com/passwords
+URLBASE=i https://downloads.pwnedpasswords.com/passwords
diff --git a/security/pwned-check/files/pwned-check.sh.in b/security/pwned-check/files/pwned-check.sh.in
index 6a4827e8b884..afb2b569856a 100644
--- a/security/pwned-check/files/pwned-check.sh.in
+++ b/security/pwned-check/files/pwned-check.sh.in
@@ -58,11 +58,11 @@ fetchpwfiles ()
fi
rm -f "$f7z"
done <<EOF
-pwned-passwords-2.0.txt 31603121046 9405806974 c267424e7d2bb5b10adff4d776fa14b0967bf0cc
+pwned-passwords-1.0.txt 12862899504 5702869528 90d57d16a2dfe00de6cc58d0fa7882229ace4a53
+pwned-passwords-update-1.txt 574389228 262300582 00fc585efad08a4b6323f8e4196aae9207f8b09f
+pwned-passwords-update-2.txt 16791180 8000810 20318090278bbd196945025bc7bf93e99f261f9a
EOF
echo "All data files have been successfully downloaded and extracted."
- rm -f "$DBDIR/pwned-passwords-1.0.txt*"
- rm -f "$DBDIR/pwned-passwords-update-?.txt*"
}
# Password lookup