aboutsummaryrefslogtreecommitdiff
path: root/security/py-acme/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 23:59:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 23:59:03 +0000
commit8b3948cdd52f3e72523acb271d2e1d9329f94626 (patch)
tree94fb2736d67704be92e833b35b5475c9b9283551 /security/py-acme/Makefile
parent91f8ea2d6b576736b1ae5d9c03beaef33f24f9db (diff)
Diffstat (limited to 'security/py-acme/Makefile')
-rw-r--r--security/py-acme/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index 122ff674cb1a..9815deb3fe05 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -1,5 +1,6 @@
PORTNAME= acme
PORTVERSION= ${ACME_VERSION}
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= PYPI
@@ -14,6 +15,8 @@ WWW= https://certbot.eff.org/ \
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}josepy>=1.13.0:security/py-josepy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=17.5.0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>=0:devel/py-pyrfc3339@${PY_FLAVOR} \
@@ -22,7 +25,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}josepy>=1.13.0:security/py-josepy@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}setuptools>=41.6.0:devel/py-setuptools@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist cryptography distutils pytest
+USE_PYTHON= autoplist cryptography pep517 pytest
NO_ARCH= yes