aboutsummaryrefslogtreecommitdiff
path: root/security/py-acme
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-10 19:45:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-10 19:45:12 +0000
commit8d9b1a8a65550fc143b7fdd8990744a1549c373b (patch)
tree3d013aa31c8b74fb6a99a7d228b185b2016ba6cd /security/py-acme
parent087c77ffecaaf2f554e304c7e3fbe90dfc9fb589 (diff)
downloadports-8d9b1a8a65550fc143b7fdd8990744a1549c373b.tar.gz
ports-8d9b1a8a65550fc143b7fdd8990744a1549c373b.zip
Update to 0.31.0
Notes
Notes: svn path=/head/; revision=492636
Diffstat (limited to 'security/py-acme')
-rw-r--r--security/py-acme/Makefile6
-rw-r--r--security/py-acme/distinfo6
-rw-r--r--security/py-acme/files/patch-setup.py6
-rw-r--r--security/py-acme/version.mk2
4 files changed, 10 insertions, 10 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index eab96c4474b5..8345d0b4d2af 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -14,12 +14,12 @@ COMMENT= ACME protocol implementation in Python
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:security/py-cryptography@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.2.3:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}josepy>=1.0.0:security/py-josepy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openssl>=0.13:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.13.1:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.10:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.6.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-toolbelt>=0.3.0:www/py-requests-toolbelt@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools>=1.0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
diff --git a/security/py-acme/distinfo b/security/py-acme/distinfo
index 0dee778002ac..e2918c80de1b 100644
--- a/security/py-acme/distinfo
+++ b/security/py-acme/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1548497863
-SHA256 (acme-0.30.2.tar.gz) = 295a5b7fce9f908e6e5cff8c40be1a3daf3e1ebabd2e139a4c87274e68eeb8f2
-SIZE (acme-0.30.2.tar.gz) = 83942
+TIMESTAMP = 1549641991
+SHA256 (acme-0.31.0.tar.gz) = 7e5c2d01986e0f34ca08fee58981892704c82c48435dcd3592b424c312d8b2bf
+SIZE (acme-0.31.0.tar.gz) = 82806
diff --git a/security/py-acme/files/patch-setup.py b/security/py-acme/files/patch-setup.py
index 3106a617a748..e05892f0fc23 100644
--- a/security/py-acme/files/patch-setup.py
+++ b/security/py-acme/files/patch-setup.py
@@ -1,11 +1,11 @@
---- setup.py.orig 2018-03-20 00:33:22 UTC
+--- setup.py.orig 2019-02-07 21:20:31 UTC
+++ setup.py
-@@ -14,7 +14,6 @@ install_requires = [
+@@ -13,7 +13,6 @@ install_requires = [
# formerly known as acme.jose:
'josepy>=1.0.0',
# Connection.set_tlsext_host_name (>=0.13)
- 'mock',
- 'PyOpenSSL>=0.13',
+ 'PyOpenSSL>=0.13.1',
'pyrfc3339',
'pytz',
@@ -24,6 +23,7 @@ install_requires = [
diff --git a/security/py-acme/version.mk b/security/py-acme/version.mk
index 25ee053b4d57..207f291990fd 100644
--- a/security/py-acme/version.mk
+++ b/security/py-acme/version.mk
@@ -1 +1 @@
-ACME_VERSION= 0.30.2
+ACME_VERSION= 0.31.0