aboutsummaryrefslogtreecommitdiff
path: root/security/py-ailment
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-09-24 16:08:34 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-09-24 16:08:34 +0000
commit02c9ee53645b1abb316db6231fe4a4218751c6ea (patch)
tree16145a327d7a67cb4a3a4316384c74717311bee6 /security/py-ailment
parent2c352e0f732836e8492ec1ee7d1d0818d1511ef3 (diff)
downloadports-02c9ee53645b1abb316db6231fe4a4218751c6ea.tar.gz
ports-02c9ee53645b1abb316db6231fe4a4218751c6ea.zip
Update the angr project ports to 9.0.4378
This patch introduces security/py-angr/Makefile.version file, which stores the shared version of all the angr ports (as ANGR_VERSION). It also stores the tagname of a distribution file, which is required for testing (ANGR_BINARIES_TAGNAME).
Notes
Notes: svn path=/head/; revision=549925
Diffstat (limited to 'security/py-ailment')
-rw-r--r--security/py-ailment/Makefile22
-rw-r--r--security/py-ailment/distinfo12
2 files changed, 16 insertions, 18 deletions
diff --git a/security/py-ailment/Makefile b/security/py-ailment/Makefile
index f7d42142544d..4081d84658e9 100644
--- a/security/py-ailment/Makefile
+++ b/security/py-ailment/Makefile
@@ -1,36 +1,36 @@
# $FreeBSD$
PORTNAME= ailment
-DISTVERSION= 8.20.1.7
+DISTVERSIONPREFIX= v
+DISTVERSION= ${ANGR_VERSION}
CATEGORIES= security devel python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= 0mp@FreeBSD.org
COMMENT= AIL, the angr Intermediate Language
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}angr>=${DISTVERSION}:security/py-angr@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}archinfo>=${DISTVERSION}:devel/py-archinfo@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}angr>=${ANGR_VERSION}:security/py-angr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}archinfo>=${ANGR_VERSION}:devel/py-archinfo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyvex>=${DISTVERSION}:security/py-pyvex@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyvex>=${ANGR_VERSION}:security/py-pyvex@${PY_FLAVOR} \
z3>0:math/z3
-USES= gmake localbase python
-USE_GITHUB= nodefault
-GH_TUPLE= angr:${PORTNAME}:c696edc9f31ecccaaa36b1e40ca1bed6c9715242:tests \
- angr:binaries:f2de6d7a0474d22130ffadd042327536a6fda114:binaries
+USES= gmake localbase python:3.6+
+USE_GITHUB= yes
+GH_ACCOUNT= angr
+GH_TUPLE= angr:binaries:${ANGR_BINARIES_TAGNAME}:binaries
USE_PYTHON= autoplist distutils
NO_ARCH= yes
pre-test:
- @${LN} -Fs ${WRKSRC_tests}/tests ${WRKSRC}/tests
@${LN} -Fs ${WRKSRC_binaries} ${WRKDIR}/binaries
do-test:
@(cd ${TEST_WRKSRC}/tests && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER})
+.include "${.CURDIR}/../../security/py-angr/Makefile.version"
.include <bsd.port.mk>
diff --git a/security/py-ailment/distinfo b/security/py-ailment/distinfo
index f8d550c0de05..706738a5abe7 100644
--- a/security/py-ailment/distinfo
+++ b/security/py-ailment/distinfo
@@ -1,7 +1,5 @@
-TIMESTAMP = 1583702768
-SHA256 (ailment-8.20.1.7.tar.gz) = 1fc110705f9dd1cfeca66876fbd87fbecea005a1d35554492c45052a2d5aa652
-SIZE (ailment-8.20.1.7.tar.gz) = 10548
-SHA256 (angr-ailment-c696edc9f31ecccaaa36b1e40ca1bed6c9715242_GH0.tar.gz) = bc6b54f62665f715c7d092ec236a4447d9135612331fa5f1d10ab073f12002f8
-SIZE (angr-ailment-c696edc9f31ecccaaa36b1e40ca1bed6c9715242_GH0.tar.gz) = 12549
-SHA256 (angr-binaries-f2de6d7a0474d22130ffadd042327536a6fda114_GH0.tar.gz) = 7bdc710d10db37d3105038eb4efda1b39e9d1149ecfaf35b1157381fe7275a4a
-SIZE (angr-binaries-f2de6d7a0474d22130ffadd042327536a6fda114_GH0.tar.gz) = 56385140
+TIMESTAMP = 1600433830
+SHA256 (angr-ailment-v9.0.4378_GH0.tar.gz) = 6b4c379265510a3b8e1478e63f8e8f6c7e613ea50dd77137949731ac51d6da58
+SIZE (angr-ailment-v9.0.4378_GH0.tar.gz) = 10399
+SHA256 (angr-binaries-9bf9c59002c2fb751ae2357f08fb9f4f8171a4ff_GH0.tar.gz) = 2c6f5130f5ee51e4cd8d891a137a347141cf155a6b2dbb248b02ac7cf11c2631
+SIZE (angr-binaries-9bf9c59002c2fb751ae2357f08fb9f4f8171a4ff_GH0.tar.gz) = 56723730