aboutsummaryrefslogtreecommitdiff
path: root/security/py-artifacts
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-05-27 21:11:37 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-05-27 21:11:37 +0000
commit36b401ac4b61112a9a49a2c60cb7927da4fd3a8f (patch)
tree8f990ac30d70bf24b49588befbcf36f3469f69b2 /security/py-artifacts
parente796077c5943c4d0dd8e39e6dc2979a446440056 (diff)
downloadports-36b401ac4b61112a9a49a2c60cb7927da4fd3a8f.tar.gz
ports-36b401ac4b61112a9a49a2c60cb7927da4fd3a8f.zip
Allow concurrent installation of py-artifacts
Notes
Notes: svn path=/head/; revision=471006
Diffstat (limited to 'security/py-artifacts')
-rw-r--r--security/py-artifacts/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/py-artifacts/Makefile b/security/py-artifacts/Makefile
index 337d6b781ccb..ee153f6cca91 100644
--- a/security/py-artifacts/Makefile
+++ b/security/py-artifacts/Makefile
@@ -3,6 +3,7 @@
PORTNAME= artifacts
PORTVERSION= 20180505
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP \
https://github.com/ForensicArtifacts/artifacts/releases/download/${PORTVERSION}/
@@ -21,8 +22,11 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${FLAVOR} \
NO_ARCH= yes
USES= python
USE_LOCALE= en_US.UTF-8
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils autoplist concurrent
DO_MAKE_TEST= ${SETENV} ${TEST_ENV} ${PYTHON_CMD}
TEST_TARGET= run_tests.py
+post-patch:
+ ${REINPLACE_CMD} "s,share/artifacts,${DATADIR_REL}," ${WRKSRC}/setup.py
+
.include <bsd.port.mk>